Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,688 Members 41,443 Now Online
XDA Developers Android and Mobile Development Forum

IMEI, Baseband Blank/Unknown, No SIM Card Detected

Tip us?
 
desperates2
Old
(Last edited by desperates2; 6th May 2014 at 06:59 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2014
Angry IMEI, Baseband Blank/Unknown, No SIM Card Detected

Hello everyone,
I have Samsung Galaxy S2 international GT-I9100. It fall into water. After that everything working fine excerpt IMEI null/null, Baseband Unknown, No SIM Card Detected. I exhibited it and dryed for a month. When I compiled it up again, same problem.

After that I decided to change the moatherboard. I bought new one, change it, turn phone on and same problem!! After that I install new ROM via Odin. And the problem still exist! How this is possible?? Oh and I want to mention that I can't access service mode. When I try to access it service mode is opened but menu is blank!

What you think the problem is?? Maybe smaller motherboard, because the small one at the bottom of the phone I didn't change. I am very desperate after so many tries so please help me.

Thanks a lot
 
desperates2
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2014
anyone???
 
slytidar
Old
#3  
slytidar's Avatar
Senior Member
Thanks Meter 39
Posts: 266
Join Date: May 2012
Quote:
Originally Posted by desperates2 View Post
Hello everyone,
I have Samsung Galaxy S2 international GT-I9100. It fall into water. After that everything working fine excerpt IMEI null/null, Baseband Unknown, No SIM Card Detected. I exhibited it and dryed for a month. When I compiled it up again, same problem.

After that I decided to change the moatherboard. I bought new one, change it, turn phone on and same problem!! After that I install new ROM via Odin. And the problem still exist! How this is possible?? Oh and I want to mention that I can't access service mode. When I try to access it service mode is opened but menu is blank!

What you think the problem is?? Maybe smaller motherboard, because the small one at the bottom of the phone I didn't change. I am very desperate after so many tries so please help me.

Thanks a lot
most probably your efs folder is corrupt or some hardware faulty. Do you have any sort of efs backup with you ?
 
MistahBungle
Old
#4  
Senior Member
Thanks Meter 3,206
Posts: 7,088
Join Date: Nov 2011
If you have no backup, you're probably boned. Download as many stock roms as you can & start flashing. If that doesn't work, take it to a local mobile repair shop; many have equipment which can re-write the IMEI to the device fairly cheaply.
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
 
desperates2
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2014
Thanks for answers, no I didn't make any backup for efs, so today I will start flashing all available ROMs for my country if this will not work I will take it to the service.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes