Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,412 Members 45,196 Now Online
XDA Developers Android and Mobile Development Forum

[HELP] Can't mound /emmc in Philz recovery

Tip us?
 
eitama
Old
(Last edited by eitama; 21st May 2014 at 02:55 PM.) Reason: Solved.
#1  
eitama's Avatar
Senior Member - OP
Thanks Meter 180
Posts: 551
Join Date: Sep 2010
Location: Hod Hasharon
Default [HELP] Can't mound /emmc in Philz recovery

SOLVED! See 2nd Post

Hi,

Galaxy S II 16GB 2.5 Years old.

I friend came to me with a problem : Waze can't start because it complains no access to sdcard (internal, no external present)

A bit fiddling and I see /storage/sdcard0 is mounted as RO!
I remount as RW, and I can now start waze, but as soon as I use the phone further, the mount reverts to RO.

I try to format it via recovery (philz) but it fails deleted odd named files in DCIM/Camera/cache.

So I try to delete the files myself but it fails.

Next up, I mount usb storage in recovery, and run windows Checkdisk, it finishes while fixing some stuff, the format still doesn't work.

Eventually using Minitool I am able to format it. BUT, now, when I boot android, it says the internal storage is damange, and attempt to format it via Android fails always.

Still, when I boot into philz, and mount usb storage, i can browse it via my W7 PC, copy and delete files freely. So I guess something is not mounted or formatted correctly. I decide to reinstall stock rom with Odin + repartition.

So I take pit file from a thread that aims to increase /data at the expense of internal storage, and I find the stock pit there and use it.

Rom flashes fully, but sdcard still not working.

What I want to do is :
Boot into Recovery and use Android commands to properly mount/map this so the phone recognizes it.

I have linux knowledge, I know how to get around a linux shell and use VI and permissions etc. I also messed sometimes with fstab on a pc to set up mount points, so I am not a complete stranger. I am rooted and need help

Any help would be appreciated.
LG G2 - D802 32GB Black @ Stock KitKat + Root
 
eitama
Old
#2  
eitama's Avatar
Senior Member - OP
Thanks Meter 180
Posts: 551
Join Date: Sep 2010
Location: Hod Hasharon
So, I searched the net for quite a few hours, and found this post :

http://forums.whirlpool.net.au/forum...5&p=-1&#bottom

Which solved my problem
I registered on that forum to thank the dude!

This command solve my problem :
newfs_msdos /dev/block/vold/259:3

I knew it will work the moment I saw the 259:3 which I saw in logcat that android cannot format.
LG G2 - D802 32GB Black @ Stock KitKat + Root
The Following User Says Thank You to eitama For This Useful Post: [ Click to Expand ]
 
MistahBungle
Old
#3  
Senior Member
Thanks Meter 3205
Posts: 7,088
Join Date: Nov 2011
Good work finding a fix yourself Hopefully other people in the same situation will find it useful
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
The Following User Says Thank You to MistahBungle For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes