Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,852 Members 41,621 Now Online
XDA Developers Android and Mobile Development Forum

[Q] HELP! Phone bricked after helroz unlock s app

Tip us?
 
Ashan85
Old
#11  
Member - OP
Thanks Meter 1
Posts: 65
Join Date: Oct 2010
Quote:
Originally Posted by graemeg View Post
the problem was you messed with 2 different tools.

All you need is the helroz unlock app, be running ics, follow the instructions, backup ya efs, and unlock.

IF YOU change ya mind and need to restore it, do it through the unlock app, NOT through the repair tool he made, yes, it does a similar thing, but if youd used the unlock app to restore efs you wouldnt or shouldnt have had any issues, your the first person i know to come unstuck with it.

be VERY CAREFUL with chains unlock app, it quite often wont work or gives ya the wrong code, which then ends up freezing ya phone, prob best to avoid that all together and take it to an unlock shop.
Yes, you are right, but I didn't thought about it, The first backup made was from the unlock tool. The second one obviously was made by the repair tool, only the problem was that it just backed up the damaged efs folder. I kept trying to restore but that was not the place for repair. Thanks to helroz that he made the backup in 2 different folders, so the bad efs didn't overwrite the good one.

Strange, I thought that chain's method was the safest, already tried it, it took a lot of minutes and prompted that couldn't find any code, I guess I won't try it again.
Should I try helroz app again? I am thinking to do so
And...one more thing, last night when it came back to life I only tested the data part of the sim. In the morning I tried to give a test call and didn't work although I had network signal.
I also tried to contact myself and it was like I had it shut off.
Everything came back to normal after shutting down and turning on again. Do you think it something I should worry,could it be because root/efs folder?
 
Ashan85
Old
#12  
Member - OP
Thanks Meter 1
Posts: 65
Join Date: Oct 2010
Oh no, Now I lost root acces, after installing busybox 1.17.1 ...what should I do?
 
Ashan85
Old
#13  
Member - OP
Thanks Meter 1
Posts: 65
Join Date: Oct 2010
anyone... superuser app cant be updated...version legacy, update fail...I know for sure this superbox messed it...
 
graemeg
Old
#14  
graemeg's Avatar
Senior Member
Thanks Meter 56
Posts: 305
Join Date: Dec 2011
Location: Dumfries and Galoway
ok, so what you need to do is a new start.

Starting with odin, do no wipe anything from recovery, just go straight to odin and flash your usual ics rom, when you get the green pass, pull the usb lead and pull the battery.

put ya battery back in and boot to recovery, standard one, do a factory reset.

After that boot ya phone up, all should be good, set it up how you want, do the usual to gain root access.

After this use once you have root access, download the appropriate CF-ROOT kernel that matches your rom, and download mobile odin from the market, unzip ya kernel and flash ya kernel through that, if ya must use odin pc, then use triangle away afterwards.

Once youve done this, any EFS backup from the previous attempts on your usb storage or sd card, DELETE the entire folders and contents.

Once youre all set, recovery, cwm and everything, get the unlock app from the market, and follow the steps exactly as is said in the instruction, and unlock your phone and backup EFS.

Now go back to your sd card, backup the efs folder it created to a safe place on your pc and keep it safe.

You should now be unlocked and sorted. after using this app DO NOT USE SGS REPAIR TOOL, it does create a different backup for different purposes, if you feel the need to restore the efs folder and relock your phone, then you must do it from the unlock app.

im confident if you do it all right, you will be ok.
Galaxy S3
Other various crappy phones


The Following User Says Thank You to graemeg For This Useful Post: [ Click to Expand ]
 
Ashan85
Old
#15  
Member - OP
Thanks Meter 1
Posts: 65
Join Date: Oct 2010
Now I understand what happened: I ran the unlock app, but the developer suggests superbox 1.17, I saw that I already had a superbox version installed but ..huh newbie...went ahead and that was the point where I lost root, I couldn't even passs step 1 with backup efs.
Thanks again....but I was on fire and again acted DIY spirit. I did so many times wipe caceh, factory data and saw that it didn't work.
So I just downloaded a stock rom (btw it's not my network rom, only the firmware matched not the baseband or csc).
-went to recovery, wiped cache, wiped data
- odin flash stock rom
- then odin root siyah
- then, and here is the clever part: screw that 1.17 recommendation and just installed galaxy s unlock without superbox, backed up efs; step 2, restart, step 3 (though I don't know if it was necessary)
And IT's UNLOCKED

Now please tell me if I did something wrong. I should copy that efs created backup in my computer right? and that's it....so much work for what it supposed to be 1 minute job...I guess I'm learning the hard way.
 
Ashan85
Old
#16  
Member - OP
Thanks Meter 1
Posts: 65
Join Date: Oct 2010
OK, here's what I will do when I come back, I'm late lol because of this,
Flash my H3G LP3 XWLP7 STOCK ROM.
now I don't know the right order, could u please help me here
Root and backup first or backup first and then root?
after these CF-ROOT Kernel - what is this actually? and why? shouldn't this syiah kernel be ok enough?
use triangle away
copy that efs folder that was created last time in my pc.
Delete? all the efs folder related files from sdcard?

what other files should I keep just in case? becaue I find myself formating the sdcard partition often. thanks
 
graemeg
Old
#17  
graemeg's Avatar
Senior Member
Thanks Meter 56
Posts: 305
Join Date: Dec 2011
Location: Dumfries and Galoway
the kernel choice you use to root is your preference, i use CFROOT, because chainfire is a tried and tested longtime reliable developer, is apps are usually solid, i was on the galaxy note and chainfires work was always the best.

Always backup the efs to the pc and keep it safe, no real reason other than you then have a backup to restore just in case your usb storage or sd card gets accidentally damaged or wiped, its always wise to have an extra copy of a backup.

i also use cfroot because it includes a version of clockworkmode recovery and the cwm app, using the cwm app you are then able to flash custom roms from recovery, stock roms from the app or even kernels, without ever having to use the pc odin again and everytime you flash a new stock rom through cwm app you keep the root, so no messing afterwards and no horrible triangles or counter increase,. its just the job.

So in order of prefernece, this is how i install and gain root, from scratch.

1 - install my stock rom through odin.

2 - i then use Initial cfroot flasher to flash the zimage of the kernel and gain root.

3 - i then install mobile odin which i purchased because its also a good flashing tool for the phone and of course i already have the cwm app from step 2.
----------------------------
in the future
If i want to flash customisations or mods, themes, custom roms, i use cwm app to boot to recovery mode and flash them from the sd card.

if i ever want to flash another stock rom, the procedure is this -

1 - create a folder in the root of your sd card called firmware.

2 - copy the unzipped file(s) from the downloaded stock rom to the folder you made, and also the matching cfroot kernel for that rom.

3 - Then run cwm app, select Flash Stock Firmware, itll ask a couple of questions and ask about root, select the cfroot kernel you copied to the card as the source for root, not to keep the stock kernel, or youll lose the root.

4 - it then reboots to flashing mode and does what it needs to do, it will again reboot and appl the multi-csc etc.

After this it will reboot to the firmware where you are now on new rom and rooted, bingo.

IF YOU GET A HANG OR BOOTLOOP
dont panic, just pull battery, put battery back in, hold the 3 buttons down to boot to recovery and do a full wipe, then restart the system, job done.

Ok people do you different kernels and methods of flashing, but seriously this is why i flash the way i do, purely so i dont have to piss around with triangle away or jigs to reset counters, all that can be avoided and anyone who flashes a custom kernel through pc odin is just being lazy, there really isnt any need to do that, you can gain root by other methods like the ones ive already mentioned, even mobile odin lets you root your phone when flashing a new rom.

It sounds like you have the system sorted now and running anyway, if its working for you with that kernel then just stick as you are, happy days, i just always stick with cfroot for the reasons ive mentioned.

Anyway glad youve got sorted now, hopefully no more problems.
Galaxy S3
Other various crappy phones



The Following User Says Thank You to graemeg For This Useful Post: [ Click to Expand ]
Tags
brick, galaxy s2, helroz, no network, unlock
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Draw a Line and Let Your Device Do the Rest with LineitApp

Over the years, since evenbefore Android entered the scene, we have striven to … more

[APK] Chrome Beta 37 Brings First Traces of Material Design

With Android L on the horizon, it’s no surprise that Google’s … more

Immersive Mode on Unrooted Devices with GMD Full Screen Immersive Mode

Everyone likes screen real estate–no question about that. The … more

Android Wear App Review: EchoWear Song Search – XDA Developer TV

Yesterday on XDA Developer TV, Producer AdamOutler tore down a Samsung … more