5,603,920 Members 42,412 Now Online
XDA Developers Android and Mobile Development Forum

HELP: Wifi Dead + Custom ROM Issues

Tip us?
 
katmandu69
Old
(Last edited by katmandu69; 3rd January 2014 at 12:32 AM.) Reason: Added more info
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jul 2011
Default HELP: Wifi Dead + Custom ROM Issues

I currently have a Galaxy S2 for almost 3 years it has served me really well, even after all this time i still enjoy it and it looks really good.
But 3 days ago i lost it. I proceeded to try to find where it was so i used Samsung's "Find My Phone", ended up not knowing where it was and i sent some commands to lock the phone up as soon as it connected to the internet.
So since i always have my Mobile Data turned off i googled, and finded an app (Android Lost) that can help me to turn on Data via sms, plus retrieve the phone's location. Ended up installing it via Play Store and sending an sms to register and enable mobile data.
Well i woke up next day and i finded out it was in a friend's car so i pick it up and it actually installed android lost, but wifi isnt working. I cant get it to work.
My phone is i9100 with 4.1.2 Stock + Dorimanx 8.43
Currently i have already done:

- Reflash Stock Firmware (I've flashed an European Version and my Carrier Version)
- Reflash Serveral Kernels:
--- Siyah Kernel (Cant flash via zip, i get status 7 refering build=i9300 + Cant flash via odin gets stuck at NAND Write(Ive already used Odin 3.07 and 1.3 but it doesnt work))
--- CWM KitKat Compatible
--- Dorimanx 8.43
--- Apolo 6.2b
--- PhilZ-cwm6-XWLSS-OXX
- Restore old 4.4.1 ROM with CWM KitKat compatible kernel, that worked fine.

I have already wiped data + cache + dalvik, plus i runned all cleaning scripts (GS2KernelWipe, GS2ROMNuke,...)

ROM's not working:
- 4.4.2 CM 11 Alpha
- MIUI v5

I can still make calls, send messages, use mobile data and use bluetooth.

The current problems i need to get solved are the following:

-- Wifi not turning ON
-- Can't flash ROM other than the Stock one, all Custom ROM's with different kernel's even after wipes get stuck at Samsung Logo

Honestly i've been searching and tried everything i found for the last 3 days and i still have hope because i saw someone saying that
if bluetooth works so may wifi because they are related in the same chip.

Can someone help ?
 
katmandu69
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jul 2011
Ok Yesterday i was able to install MIUI v5 ROM after installing SpeedWizz Kernel 4.2 via ODIN.
Still no Wifi though !

Is it true the wifi and bluetooth module are the same ?
 
DeNiZ85
Old
(Last edited by DeNiZ85; 22nd March 2014 at 05:26 PM.) Reason: typing errors on my s2 and annoying t9
#3  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Feb 2014
Default i have same kind of...

Hey everyone

I have kind of the same problem but my happen only when i try tot install custom kernel..
If i install just only a ROM + gapps all oké..
Wifi also.. But when ever i install what ever kernel the wifi stops functioning..
Tried philz appolo gustavos my favorit
one: dorimanx but all no wifi..
ROM function perfect with wifi:
Omni 442 Latest
Beanstalk 442 latest
MokeeOS 442 latest
Neatrom 442 latest
Cm11 442 latest
Kind of all 442 rom working flawless with wifi on
Only custom kernels have problem... All of them i could find here on xda

The problem started 2 days i go when i wanted tot update my current omni version tot latest stable..
Zo i thought i do fresh installation zo i wiped everything ( system data chace sd1 before wipe i cleand emmc)installed rom OK pa gapps stock OK turbo boost mod script set to 300mb chace OK swapSDcm11 OK Installed dorimanx v10.something latest OK
Reboot everything OK till wifi...
I can touch wifi switch.. It slides... But stays grey on ON... Then switches back tot OFF...
If i do full wipe...
Install everything above except kernel.. Everything oké..
Full wipe...
Only rom+ kernel no wifi...
What ever combo...

Zo now i stuck on omni kernel... It performs oké.. But i miss gpu overclock andere UV...

Btw.. Pa gapps stock + will fit i have 1gb system partition

Btw.. Turboboost mod 300mb swap on cache partion will work cause i have 375mb cache partition

Btw.. 8gb data partition 75mb preload for some symlinks 4something GB emmc.. everyother partition kept stock...

Its not my configuration of my PIT tabel excluded..
It worked till 2 days ago with omni 442stable 01-2014 with 02-2014 dorimanx...

Altough i did Flash a radio couple of weeks ago.. But still it worked perfectly till 2 days ago...

I learned my lesson.. When it is running.. Let it run..

Anyone can help...

Thanks
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes