Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,319 Members 50,542 Now Online
XDA Developers Android and Mobile Development Forum

I9100 loose imei, restored, lost again after few reboot

Tip us?
 
CyD.be
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 15
Join Date: Dec 2007
Default I9100 loose imei, restored, lost again after few reboot

Hello, i have a problem with my phone and imei.

When i reboot i loose imei, i can restore and if i put my sim card after boot, i can use it. If i reboot i go back to 004999....

Any ideas ?
Tried flashs back to 2.3 4.1.2 and current on cyanogen11
 
CyD.be
Old
#2  
Junior Member - OP
Thanks Meter 1
Posts: 15
Join Date: Dec 2007
I see my nvdata.bin.md5 and the md5.bak are not the same

Is this the source of problem ?
 
CyD.be
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 15
Join Date: Dec 2007
I get my imei back with gs2 repair , it does correspond to my imei. The problem is if i do chmod 755 nv_data.bin, i get a 04999... Imei ...
 
CyD.be
Old
#4  
Junior Member - OP
Thanks Meter 1
Posts: 15
Join Date: Dec 2007
Could get it back:
Flashed 2.3.5, rooted, used gs2_repair, chowned nv_data.bin -> imei ok
 
CyD.be
Old
#5  
Junior Member - OP
Thanks Meter 1
Posts: 15
Join Date: Dec 2007
Flashed 4.1.2 imei ok, but no pin request.

Flashed cwm6 installed cm10.1.3 : imei and pincode ok. Call ok.

Flashed cm11: imei goes 04999


Why is this happening in cm11 and not cm10.1.3?

Is it permission on a file in efs ?

I would like to go cm11. Again
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes