Question [Q] i9100g Camera Error v4.4.3 omni

Camera error message: can't connect to the camera.

version 4.4.3
omni 4.4.3-20140606-i9100g-nightly

I used the stock camera last week and everything was fine. Tried using it today and got the error message. Tried a few fixes, different camera apps (they crash) and reinstalling the stock apk. Not sure if I was using the correct stock apk because installation failed. Just tried the torch app and it crashed as well. Any ideas? Thanks