FORUMS

XPrivacy for Android Lollipop – XDA Xposed Tuesday

Have you ever been on the Google Play Store and saw an app that you wanted to … more

How a HTC Droid Eris Changed a Members Life

Rarely can a member say that Android development or XDA had a profound effect on … more

XDA Office Space: Frankenstein’s Perfect IM Client?

The portal’s decentralized XDA office lies in a Hangouts chatroom, where … more

Which IM Client on Android is best?

With so many different messengers to choose from, it can be tough to find the best one for you and … more
Post Reply Subscribe to Thread Email Thread

ICS XXLPQ Build: Error Couldn't install on USB storage or sd card

15th March 2012, 03:51 AM |#1  
OP Junior Member
Thanks Meter: 0
 
More
Hi all, I just installed the official pack from Samsung, and for whatever reason I'm getting this error message on only CERTAIN apps straight from App Store: Error Couldn't install on USB storage or sd card.

Any idea how to fix?
One solution i've found is unmounting SD card during installation but I want something more permanent.

I've found this online but not sure if it works with the latest version of ICS:
http://forum.xda-developers.com/show....php?t=1503835

I'm worried if I use this method it will clear my layout and settings that i have now.

Please help thanks!
 
 
15th March 2012, 08:44 AM |#2  
Junior Member
Thanks Meter: 7
 
More
I have the same problem. It worked after I flashed the official ics firmware. But then I flashed the Darky Rom LPQ kernel to get root and CWM. Now I can't install apps that are installed directly to SD CARD.

Edit: Flashing back the original (Stock LPQ) Kernel, it works again.

Sent from my GT-I9100 using xda premium
Last edited by primedape; 15th March 2012 at 01:31 PM.
15th March 2012, 04:29 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Talking XXLPQ - do not move apps in SD Card
Same problem here... flashed XXLPQ and CF-rooted, then all the apps in SD card cannot be loaded, cannot re-install neither...

my solution: flash the XXLPQ again, then all the apps in SD card works temporary, then -> setting -> Application -> 'on SD', move all the (checked) apps to phone instead of SD card; then restart and make sure it works fine.

Also, I CF-rooted the phone again and install TITANIUM BACKUP and backup all the apps & data in case I need to flash the firmware back to Android 2.3.5 before this error get fixed.
15th March 2012, 04:41 PM |#4  
danmullen's Avatar
Senior Member
Flag Durham, UK
Thanks Meter: 152
 
More
This was a known issue with LPQ and CF-Root 5.3. It's fixed in CF-Root 5.4
The Following User Says Thank You to danmullen For This Useful Post: [ View ]
15th March 2012, 04:43 PM |#5  
Senior Member
Flag Lohja
Thanks Meter: 11
 
More
Actually the apps you cant install are not for android 4.0.

Tty self u can install apps designed for ICS but not apps only for GB
15th March 2012, 11:32 PM |#6  
Junior Member
Flag Fleet
Thanks Meter: 4
 
More
Confirm
Quote:
Originally Posted by danmullen

This was a known issue with LPQ and CF-Root 5.3. It's fixed in CF-Root 5.4

Just mentioning I can confirm the new version of CF-Root works, had one app giving me this error, Flashed the CF-Root 5.4 and works again afterwards.
17th March 2012, 10:36 AM |#7  
vibecatalin's Avatar
Senior Member
Thanks Meter: 64
 
Donate to Me
More
I can also confirm that upgrading to CF Root 5.4, the problem it's fixed.
17th March 2012, 08:19 PM |#8  
decodex's Avatar
Senior Member
Thanks Meter: 81
 
More
also siyah kernel alpha 7 version does.
22nd March 2012, 08:11 AM |#9  
OP Junior Member
Thanks Meter: 0
 
More
thanks all for your help.. worked great flashing 5.4
22nd March 2012, 10:20 PM |#10  
Zaatour36's Avatar
Member
Thanks Meter: 2
 
More
thank you sooooo much this is soo helpful,

I will try it and update back,

I'm probably going with Syiah, but'll see which one is better


UPDATE: just flashed CF-Root and worked perfectly!

W W W download.chainfire.eu/152/CF-Root/SGS2/CF-Root-SGS2_XX_XEO_LPQ-PROPER-v5.4-CWM5.zip

on my i9100 XXLPQ using Spik. Pure ICS 7.0 ROM
Last edited by Zaatour36; 22nd March 2012 at 11:41 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes