Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,756 Members 50,895 Now Online
XDA Developers Android and Mobile Development Forum

ICS XXLPQ Build: Error Couldn't install on USB storage or sd card

Tip us?
 
alextn99
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Apr 2011
Default ICS XXLPQ Build: Error Couldn't install on USB storage or sd card

Hi all, I just installed the official pack from Samsung, and for whatever reason I'm getting this error message on only CERTAIN apps straight from App Store: Error Couldn't install on USB storage or sd card.

Any idea how to fix?
One solution i've found is unmounting SD card during installation but I want something more permanent.

I've found this online but not sure if it works with the latest version of ICS:
http://forum.xda-developers.com/show....php?t=1503835

I'm worried if I use this method it will clear my layout and settings that i have now.

Please help thanks!
 
primedape
Old
(Last edited by primedape; 15th March 2012 at 01:31 PM.)
#2  
Junior Member
Thanks Meter 7
Posts: 14
Join Date: Mar 2009
I have the same problem. It worked after I flashed the official ics firmware. But then I flashed the Darky Rom LPQ kernel to get root and CWM. Now I can't install apps that are installed directly to SD CARD.

Edit: Flashing back the original (Stock LPQ) Kernel, it works again.

Sent from my GT-I9100 using xda premium
 
kenyung
Old
#3  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: May 2011
Talking XXLPQ - do not move apps in SD Card

Same problem here... flashed XXLPQ and CF-rooted, then all the apps in SD card cannot be loaded, cannot re-install neither...

my solution: flash the XXLPQ again, then all the apps in SD card works temporary, then -> setting -> Application -> 'on SD', move all the (checked) apps to phone instead of SD card; then restart and make sure it works fine.

Also, I CF-rooted the phone again and install TITANIUM BACKUP and backup all the apps & data in case I need to flash the firmware back to Android 2.3.5 before this error get fixed.
 
danmullen
Old
#4  
danmullen's Avatar
Senior Member
Thanks Meter 152
Posts: 677
Join Date: Dec 2009
Location: Durham, UK
This was a known issue with LPQ and CF-Root 5.3. It's fixed in CF-Root 5.4
The Following User Says Thank You to danmullen For This Useful Post: [ Click to Expand ]
 
blizzari
Old
#5  
Senior Member
Thanks Meter 11
Posts: 174
Join Date: May 2011
Location: Lohja
Actually the apps you cant install are not for android 4.0.

Tty self u can install apps designed for ICS but not apps only for GB
 
Zeus65
Old
#6  
Junior Member
Thanks Meter 4
Posts: 25
Join Date: Mar 2012
Location: Fleet
Default Confirm

Quote:
Originally Posted by danmullen View Post
This was a known issue with LPQ and CF-Root 5.3. It's fixed in CF-Root 5.4
Just mentioning I can confirm the new version of CF-Root works, had one app giving me this error, Flashed the CF-Root 5.4 and works again afterwards.
 
vibecatalin
Old
#7  
vibecatalin's Avatar
Senior Member
Thanks Meter 44
Posts: 660
Join Date: Jul 2008

 
DONATE TO ME
I can also confirm that upgrading to CF Root 5.4, the problem it's fixed.
SONY Xperia Z 16 GB Black
IPad 4 16GB Wi-FI Black
 
decodex
Old
#8  
decodex's Avatar
Senior Member
Thanks Meter 81
Posts: 139
Join Date: Mar 2012
also siyah kernel alpha 7 version does.
 
alextn99
Old
#9  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Apr 2011
thanks all for your help.. worked great flashing 5.4
 
Zaatour36
Old
(Last edited by Zaatour36; 22nd March 2012 at 11:41 PM.)
#10  
Zaatour36's Avatar
Member
Thanks Meter 2
Posts: 48
Join Date: Mar 2012
thank you sooooo much this is soo helpful,

I will try it and update back,

I'm probably going with Syiah, but'll see which one is better


UPDATE: just flashed CF-Root and worked perfectly!

W W W download.chainfire.eu/152/CF-Root/SGS2/CF-Root-SGS2_XX_XEO_LPQ-PROPER-v5.4-CWM5.zip

on my i9100 XXLPQ using Spik. Pure ICS 7.0 ROM

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes