Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,687 Members 41,264 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Incorrect Battery Stats / Problems with USB Connectivity

Tip us?
 
h4zm993
Old
(Last edited by h4zm993; 14th August 2014 at 03:34 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
Default [Q] Incorrect Battery Stats / Problems with USB Connectivity

Hello developers!

My newold S2 got a few issues and i don't know how to handle them. There was no answer by Google, so i just registered on this great site.

A few month ago, my battery didn't show the correct charge anymore. It jumped from fully charged to less than fifty percent and slowly moved up to about eighty percent. Freaking out! When i connected the phone to my PC nothing happened - it just charged the battery instead of going into mass storage mode. At this point, i used the latest stock firmware and decided to go on a costum rom, recalibrate the battery and that standard stuff. Everything went fine, at least for the first few plugins. I tried another kernel, another rom, but always the same freaking problem. Now i use SlimSaber 4.4.4 updated this morning.

I guess there are problems with the USB controller or something. The phone doesn't recognize that it is unplugged for hours - and this is causing the issues with the mass storage mode. Just nooby guessing - i hope you can help me. Reboot doesn't fix the problem.

I tried to explain the problem as good as i can, sorry if there are missing informations. I don't even know how to explain the problem in german... I attached some screenshots for better understanding. Looking at the clock may show the exact problem. When i took the screenshots, the phone was already unplugged for about two hours.

Do you have an idea whats going wrong and what will fix the problem?

#edit// For any reason, i was able to connect in mass storage mode by mounting in TWRP.
#moredit// For any reason, mounting in TWRP doesn't work anymore.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-08-14-12-45-10.png
Views:	32
Size:	69.0 KB
ID:	2896846   Click image for larger version

Name:	Screenshot_2014-08-14-12-53-59.png
Views:	27
Size:	75.1 KB
ID:	2896847   Click image for larger version

Name:	Screenshot_2014-08-14-12-45-34.png
Views:	26
Size:	66.7 KB
ID:	2896848  
 
theares2014
Old
#2  
Senior Member
Thanks Meter 7
Posts: 229
Join Date: Feb 2011
Servus,

I cannot tell you that the battery fix will work for you but for this device common battery stats wiping apps do not work at all.
Somewhere in the Galaxy SII part of this board there is a workaround for that.

1. Turn off your phone (battery between 0% and 50%) and charge it.
2. Wait till it reached 100%
3. Pull out both - battery and charging cable.
4. Wait for at least 3 minutes.
5. Restart and propably do this again

-> However, you should look for the exact description in the original thread.

The other problem could be due to your rom - you better ask there .
Samsung Galaxy SII i9100 | Stock | Android 4.0.3 | root
Asus Eee Pad Transformer | Android 4.0.3 | 32GB | root

Lovely old device:
LG GT540 | Soft-Mod of CyanogenMod 6.1 Utopia | Android 2.2
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes