Post Reply

Keep losing ringtone and notifications settings on reboots

OP corvus.corax

26th July 2014, 10:22 AM   |  #1  
corvus.corax's Avatar
OP Senior Member
Flag Athens
Thanks Meter: 202
 
518 posts
Join Date:Joined: Jul 2013
Nearly every time I restart or reboot the phone, including from recovery, I lose the settings I have for ringtone, default notifications, and for tones for various messaging apps and I have to reset them. This is a big annoyance . I am using a custom KK ROM, in this case NeatROM, What is weird is that when I first migrated to CyanFox at the beginning of the year, it didn't happen. Then, one day it started and continued with the other KK ROMs I used - which are NeatROM and Mokee (though it happens less on Mokee). At first, I thought it was the media scanner, so (thank you, Sale) I disabled it in NeatROM and tested that. Nope. Not the cause of the problem. I also thought it might be because the notifications and ringtones I use are stored on my external SD card (formatted for exFAT), but when I moved them all to the internal SD, the problem remained. Any ideas how to resolve this? Thanks in advance.
Last edited by corvus.corax; 26th July 2014 at 05:02 PM.
28th July 2014, 09:27 PM   |  #2  
corvus.corax's Avatar
OP Senior Member
Flag Athens
Thanks Meter: 202
 
518 posts
Join Date:Joined: Jul 2013
A little update. I thought I could fix the problem by moving my preferred sounds to /system/media/audio. For good measure, i converted them from mp3 to ogg format. But moving them didn't do anything. The problem persists.
29th July 2014, 11:15 AM   |  #3  
Junior Member
Thanks Meter: 3
 
22 posts
Join Date:Joined: Mar 2012
More
Try working with default ringtones . When you say you loose ringtones do you mean it turns to default or none ? I had a problem and I used to disable media scanner via an app . When I reboot my ringtones and alarms would turn to none ( it said none or smthing close to that in the settings ) . Else it might be a bug in the rom . Factory reset and changing the rom is always a sure option .
30th July 2014, 09:03 AM   |  #4  
corvus.corax's Avatar
OP Senior Member
Flag Athens
Thanks Meter: 202
 
518 posts
Join Date:Joined: Jul 2013
The ROM has defaults for the ringtone and notification tone. When I lose my "customized" settings in reboots, they are replaced by the defaults. This happens on all 3 KK ROMs I've used, but not on stock or rooted JB. I've tried factory resets, dirty installs clean installs, fresh installs from stock, reformats. Nothing fixes it. I am beginning to think the phone itself is deteriorating.
8th August 2014, 09:01 PM   |  #5  
corvus.corax's Avatar
OP Senior Member
Flag Athens
Thanks Meter: 202
 
518 posts
Join Date:Joined: Jul 2013
I discovered that the sounds settings are preserved if i do a soft or hard reboot from within xposed installer. That's pretty weird but maybe points to a solution to the problem?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes