Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,816 Members 38,895 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Imei and baseband disappeared after dropping the phone

Tip us?
 
sinabey
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
Default [Q] Imei and baseband disappeared after dropping the phone

Hello,

I wrote the most essential parts in bold so that you'll know the parts to skip if you don't want the details.

I've been having this weird problem with my phone. I dropped my phone, the bottom left side of the screen cracked a little and as a result, the phone lost it's network connectivity. My first thought was that the sim card had dislodged but it was fine. Then I opened the case to check if any connectors were out of their place. As expected, the usb connector assembly's (or whatever it is called. basically the component that the usb port is attached to) connector was halfway up, so i placed it back and turned it on and it still didn't fix the problem.

Then trying to find out if I'll be able to see any clues, I went to the settings page and realised both the imei and the baseband is gone.

I searched and searched and most of the time my problem seems to be fixable through rooting and repairing the efs files. Though this solution applies to phones that had software problems, not a physical damage. I tried it anyway but all I got is a rooted android with no imei now.

So the question is, does anyone have any experience in a situation like this? Physical damage causing the imei to disappear? Or is there anything you'd like to suggest?

Thanks in advance
 
TheImpossibleEnemy
Old
(Last edited by TheImpossibleEnemy; 8th April 2014 at 10:38 AM.)
#2  
TheImpossibleEnemy's Avatar
Senior Member
Thanks Meter 128
Posts: 322
Join Date: Feb 2014
Location: Local Bubble
This is weird.This may sound implausible,but I think your efs somehow got corrupted in this accident.Restore an efs backup if you have one.It won't hurt.This will rule out any possible efs problems.
GT-i9100
SlimSaber Reborn 4.3.1
Dorimanx 10.43v112
 
sinabey
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
Quote:
Originally Posted by TheImpossibleEnemy View Post
This is weird.This may sound implausible,but I think your efs somehow got corrupted in this accident.Restore an efs backup if you have one.It won't hurt.This will rule out any possible efs problems.
thank you for the reply, when i first upgraded my phone to 4.1.2, i should have created a backup by using adb just because i can. if I can locate the file maybe that could solve.

do you think there is any chance that I actually caused a permanent physical damage to the board or a component which could permanently reduce my phone to an expensive mp3 player?
 
MistahBungle
Old
#4  
Senior Member
Thanks Meter 3205
Posts: 7,088
Join Date: Nov 2011
Quote:
Originally Posted by sinabey View Post
do you think there is any chance that I actually caused a permanent physical damage to the board or a component which could permanently reduce my phone to an expensive mp3 player?
I haven't seen an instance of this in the 2.5 yrs I've been here, but it's definitely possible. Put it this way, seems like too much of a coincidence it would go away immediately after you drop it, assuming you hadn't modded it in any way shortly before you dropped it (flashed a rom/modem/kernel/whatever).

Only way you're going to rule this in/out for certain is to take it to a mobile repair shop for diagnosis.

Edit - What specific model are we talking about ?
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
The Following User Says Thank You to MistahBungle For This Useful Post: [ Click to Expand ]
 
TheImpossibleEnemy
Old
#5  
TheImpossibleEnemy's Avatar
Senior Member
Thanks Meter 128
Posts: 322
Join Date: Feb 2014
Location: Local Bubble
As you said that usb flex connector got loose then maybe this connector or its socket on mainboard got damaged.
It's a mystery to me how did your imei/baseband etc disappeared.
As @MistahBungle suggested,if you can't fix it by yourself,go for professional diagnostics.
GT-i9100
SlimSaber Reborn 4.3.1
Dorimanx 10.43v112
 
sinabey
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
thanks for the replies.

the model is I9100 and the ssn is i9100GSMH.

yes it was not modded at all actually. and as it seems the backup files on my computer are 0 bytes. unless the .ab files are just headers pointing to the actual backup content then it means that the backup process went wrong and i did not notice at the time. though the header hypothesis is unlikely because it would at least be some bytes if not zero...

i was hoping that this was something that is known to happen with a solution, but i guess my only option right now it so take it to the service. which i was avoiding, because here it almost costs much as just buying a working second hand one. but at least i can get the diagnosis. i'll post the result up here after I have it looked, in case it happens to anyone else.
 
TheImpossibleEnemy
Old
#7  
TheImpossibleEnemy's Avatar
Senior Member
Thanks Meter 128
Posts: 322
Join Date: Feb 2014
Location: Local Bubble
did you looked for backups in phone's internal and external sdcards too?
GT-i9100
SlimSaber Reborn 4.3.1
Dorimanx 10.43v112

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes