Post Reply

Phone doesn't shut off and I can't access recovery.

24th January 2014, 12:04 AM   |  #1  
Odinuts's Avatar
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Oct 2013
More
Hello, every time I shut my S2 off, it automatically boots itself up again unless it's on a charger and I can't access recovery mode by pressing power, home and volume up buttons. But I somehow can access download mode! Only way to go into recovery is by rebooting into it from the advanced reboot menu when the device is up. I've had this same issue on CM 10.2, SlimBean and OmnirROM but I can go into recovery by pressing the buttons if I'm on stock Samsung jellybean for some reason.

Sent from my GT-I9100 using Tapatalk
24th January 2014, 06:31 AM   |  #2  
akhil17kr's Avatar
Senior Member
Flag gurgaon
Thanks Meter: 26
 
338 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by Odinuts

Hello, every time I shut my S2 off, it automatically boots itself up again unless it's on a charger and I can't access recovery mode by pressing power, home and volume up buttons. But I somehow can access download mode! Only way to go into recovery is by rebooting into it from the advanced reboot menu when the device is up. I've had this same issue on CM 10.2, SlimBean and OmnirROM but I can go into recovery by pressing the buttons if I'm on stock Samsung jellybean for some reason.

Sent from my GT-I9100 using Tapatalk

flash stock rom .. then again install any other custom after data wipe/factory reset and check whether if it can go in to recovery after phone is switched off ??
if still after you switched off phone it does restart on itself or cannot enter into recovery then you better take it to the samsung care if it's still in warranty ..

Have it is water damaged before ??
if it is water damaged then the motherboard or power ic may be faulty which results into automatic restart of phone even after POWERING OFF the device..
24th January 2014, 07:21 AM   |  #3  
Odinuts's Avatar
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Oct 2013
More
Quote:
Originally Posted by akhil17kr

flash stock rom .. then again install any other custom after data wipe/factory reset and check whether if it can go in to recovery after phone is switched off ??
if still after you switched off phone it does restart on itself or cannot enter into recovery then you better take it to the samsung care if it's still in warranty ..

Have it is water damaged before ??
if it is water damaged then the motherboard or power ic may be faulty which results into automatic restart of phone even after POWERING OFF the device..

I don't think it's been water damaged before but I did have some issues with the USB port where the phone randomly thought it was charging when it wasn't even connected to a charger but I fixed that using a toothpick to clean up the port. Device isn't in warranty anymore, unfortunately. But I recall having to go to stock before and doing the data wipe and factory resetting process, so it's all kinda weird.

Sent from my GT-I9100 using Tapatalk
24th January 2014, 09:37 AM   |  #4  
akhil17kr's Avatar
Senior Member
Flag gurgaon
Thanks Meter: 26
 
338 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by Odinuts

I don't think it's been water damaged before but I did have some issues with the USB port where the phone randomly thought it was charging when it wasn't even connected to a charger but I fixed that using a toothpick to clean up the port. Device isn't in warranty anymore, unfortunately. But I recall having to go to stock before and doing the data wipe and factory resetting process, so it's all kinda weird.

Sent from my GT-I9100 using Tapatalk

Try this :

BOTH IN STOCK and CUSTOM ROM (After Following proper instructions provided by OP to install ROM)

a) Try whether your phone does boot up again after switching off again ?
b) If you can enter recovery when phone is switched off ?

POST results here..
If the problem persists only in custom ROM not in STOCK then its SOFTWARE ISSUE..
IF still this Problem is in Stock ROM too then its HARDWARE PROBLEM ..

Take your phone to the Local Repair Shops to check for USB and MAINBOARD .. according to the results ofcourse..
The Following 2 Users Say Thank You to akhil17kr For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes