Default [Q] Phone is not recognized in download mode (hardware problem)

Hi guys, i realy need your help, my phone is dead.

My I9100 worked fine for two years, I flashed lots of custom firmwares by Odin. Half a moth ago, when I was going to sleep, I plugged in the charger as usually, and noticed, that it started beeping occasionally. On the display it indicated smth like: Charging... than Not Charging... than Charging and so on.
I thought that I plugged the charger incorrectly and replugged it, but it didn't helped. I was very tired and just simply turned the soud off and left the phone charging. In the morning it indicated that it is charging even when the charger was unplugged.
So I've flashed the firmware - no help, than kernel from stock to fillz - no help , than siyah than again to stock - no help. All flashings were maid via CWM. I realized that flashing will not help when I turned off the phone and it was indicating that it is charging.
I decided not to do anythig. Only USB mode didn't worked because when you want to use your phone as USB you should open the apropriate mode on the phone than there will be smth like : plug the USB data cable to enter the USB data transfer mode. I couldn't do this because my phone thought that the cable is already plugged. In forums i've got hints that my micro usb should be cleaned or small board should be replaced. So i decided to clean it. I disassembled the phone and cleaned that board with micro USB. Than turned on the phone, and connected the cable. Phone recognized it and I managed to transfer files from pc to phone. From this point I can say that all terminals on micro USB are ok.
When i unplugged the cable, phone thought that it is plugged((

The most awful part:

I decided to flash it one more time and go to stock via backup made by CWM a year ago.
But during this process the phone made a reboot by itself and after that there was no loading. I can see only name of the device and thats it.
No recovery. Only download mode.
When i connect it to PC in download mode, there is a sound that USB is connected but the device is Unknown. There is no any information about this device in dev manager on PC. I tried two USB cables, all usb ports, two laptops, all versions of USB drivers for my phone.

Earlier, drivers worked well, but now i can't understand where is the problem: Is the problem still connected with my micro usb port or i just erased boot sector and it is already brick.

I gave my phone to service center, they told that they can't help me with this. They say that usb is ok, we don't know why it is not detecting by pc.

Can the board replacement help in this issue or maybe i can do smth. in linux with my device ??? I'll appreciate any suggestions.

Yesterday I talked to representatives of service center and they told me that the problem is that internal memory is damaged and they cant flash the phone.
I took the phone and tried to flash it via Heimdall with brick fix pit.
After using this pit file, the phone was flashed normally and even turned on normally.
But in the phone info menu I saw no any data about internal memory. (It was damaged and required format). I tried format through phone menu and it did nothing.
I decided to flash the phone via Odin with normal 16 GB pit file and had a bad luck. I experienced freez during repartition. After this, phone is a complete brick.
When I connect it to PC without battery pressing vol down and rower buttons it connects as unknown device but there is nothing on the phone display. No recavery no download mode. Nothing - just reflection of my frustrated face).
Currently i'm tring to make a Jtag, maybe it'll put it in the download mode, but hope is dying....
I've herad somewhere that it is possible to put it in the download mode in linux. If somone did this, could you please give me the contact of this person?