Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,957 Members 53,956 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Can't root phone or install cyanogenmod, tried mac and ubuntu

Tip us?
 
jibjibjib
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Sep 2014
Question [Q] Can't root phone or install cyanogenmod, tried mac and ubuntu

Hi

I am really hoping someone can help me. I have been trying for weeks now to fix my phone: Samsung Galaxy S2 GT-i9100G. In July I stupidly updated from Gingerbread, which was working perfectly, to 4.1.2. Now my phone is practically useless. It switches itself off all the time, unless I just use it as a clock. Essentially I can only use it when it is plugged in. So I decided to try rooting it to do a battery calibration. With my mac I used heimdall to flash a rooted kernel and didn't get the full messages I expected: the final line about reattaching drivers was missing. Then when I used a terminal simulator or superuser on the phone I got an error: no su binary installed etc. So I decided to try using my linux machine last night. This time I got the full feed in terminal, so it looked like the installation was successful, but the same thing: the phone was not actually rooted.

I had also tried unsuccessfully to go back to gingerbread using the mac, no luck. Last night I was so frustrated that I decided to try installing cyanogenmod. At this point I have very little to lose: the alternative is to pay to unlock my old nokia and use that as an actual phone. I tried using the cyanogenmod wiki instructions (which I am not allowed to link to) but pushing to the sdcard didn't work. I got some error: is a directory. Note that when doing the factory reset through CWM recovery it said there was an error formatting the sdcard (something like android_secure. I should have written all of this down). Then I tried sideloading but I just got stuck on the sideload screen on the phone and had to restart the phone. I also found a guide about rooting through CWM recovery but it involves the same push method which just doesn't work. I guess that the problem is the sdcard formatting (note that after last night's factory reset I still have photos on my phone which shouldn't have survived) but I don't know what to do about it. I did try "format sdcard" from recovery mode but that failed.


I am comfortable with command line stuff but will need step by step instructions. I am not an expert at all, have just been reading a lot over the last few weeks trying to fix this. My flash counter now shows 14 or something (some resulted in soft bricking). I don';t know what I am doing wrong. Please help!
 
spider1029
Old
#2  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Aug 2014
Try to flash it with Odin.
 
jibjibjib
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Sep 2014
Quote:
Originally Posted by spider1029 View Post
Try to flash it with Odin.
I'd have to get hold of a windows machine (none at home or work). Why do you think that would work better?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes