5,598,718 Members 38,861 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Rooting - which kernel please?

Tip us?
 
Chris911t
Old
(Last edited by Chris911t; 6th December 2011 at 11:35 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 17
Join Date: Nov 2011
Default [Q] Rooting - which kernel please?

Since I can't post in the main thread in the development section, I wanted to make sure I have the right kernel for the CF-Root process after reading the post I've quoted at the bottom of this post.

My phone is on Android 2.3.4 and XWKI4.

The latest rooting kernel that I seem to be able to get from the CF-Root thread is: CF-Root-SGS2_XW_NEE_KI4-42-v4.2-CWM4.zip

That seems to have CWM4 in it so I'm worried that I'll have the same problem as the poster below, (since he is also on KI4)?

Thanks in advance.

-------------------------------------------------------------------
Quote:

Originally Posted by mcmg
Can't root my SGS2. IV4.4. KI4tar is most modern KI4 version I can get on this thread and it won't root on CF-Root 5.0 and a CWM that requires v5 or later. What to do?

Reply (lt_ler):
As I do not trust your signature, please post your current ROM and kernel versions.
Then it is a lot easier to recommend a corresponding CF-Root kernel which will root your phone.
 
Cosmic Blue
Old
#2  
Senior Member
Thanks Meter 197
Posts: 855
Join Date: Mar 2008
Location: Toronto
you have the correct cfroot for the version you have posted..

other poster did not read or know what he was doing.

IV4.4.KI4tar does not exist.
The Following User Says Thank You to Cosmic Blue For This Useful Post: [ Click to Expand ]
 
donalgodon
Old
#3  
donalgodon's Avatar
Senior Member
Thanks Meter 617
Posts: 3,675
Join Date: Jan 2010
Honestly, pretty much any of the CF-Root kernel versions will work.

I realize that people like to keep the same kernel as the stock ROM and that this is the philosophy behind it, because I am one of them, but in reality, the kernel version itself doesn't change enough to make any significant difference.

Try it out. Flash any version with any Stock ROM.

Bet they all work. I tried a few (not all) and they all worked fine.
PHONE: Samsung Galaxy Note 3 (SM-N900)
ROM: [KitKat][4.4.2]Stock N900UBUDNB2 FEB 14, 2014 CF-Auto-Root
RADIO: N900UBUDNA1
KERNEL: Stock
RECOVERY: CWM 6.0.4.7
WARRANTY BIT: 1


STATUS: Flashing Addict!





Quote:
“He who answers a matter before he hears it, It is folly and shame to him.” Proverbs 18:13
The Following User Says Thank You to donalgodon For This Useful Post: [ Click to Expand ]
 
Chris911t
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 17
Join Date: Nov 2011
Default Thanks

Quote:
Originally Posted by donalgodon View Post
Honestly, pretty much any of the CF-Root kernel versions will work.

I realize that people like to keep the same kernel as the stock ROM and that this is the philosophy behind it, because I am one of them, but in reality, the kernel version itself doesn't change enough to make any significant difference.

Try it out. Flash any version with any Stock ROM.

Bet they all work. I tried a few (not all) and they all worked fine.
Thanks. I'm just getting started on all this, so apologies if I'm being a bit dense

I understood that using the same version (KI4 etc) would be useful in avoiding the "yellow triangle" thing where you have to do some fiddling about re-flashing with the same version ID. I could probably just about manage to recover from a situation like that, but I'd rather not take any more risks than I have to (being a noob at this).

Since Cosmic Blue has confirmed that I have the right kernel, I'll use that and keep fingers crossed. One day when I get better at this I may be more adventurous!

Thanks to both of you for the help
Tags
root xwki4 cwm4
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes