5,605,685 Members 48,333 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Very Slow Mobile Network, Kinda Strange.

Tip us?
 
teror300
Old
(Last edited by teror300; 29th December 2013 at 08:47 PM.) Reason: Additional Info
#1  
Junior Member - OP
Thanks Meter 1
Posts: 9
Join Date: Jun 2012
Location [Q] Very Slow Mobile Network, Kinda Strange.

Hello everyone, first of all I should post this to Android Development section but since system tells me I do not have 10 posts, I thought I can post this here.

Well basically I was using Disaster ROM for my SGS2 (International) (I'm in Turkey), and I wanted to use Biftor Rom which was actually KitKat and I didn't know that I should install CM 10.2 or newer first to install other KitKat Roms. So I actually softbricked my phone I was only able to go into download mode. So I flashed my phone with stock 4.0.3 using Odin. But I realised that my mobile network was actually slow as hell. Sometime it can't even connect. But I was like "Oh anyways, it will go away if I flash custom rom". But it didn't. I checked my IMEI and it was there, valid. I flashed my phone 4 or 5 times more with different ROMs. But no luck.

Then I heard an app called GetRIL, because someone told me that my baseband/modem thing might be corrupted. When I opened the app I saw that it says "Unknown RIL". So what should I do? I tried setting APN manually, then automatically by my Vodafone Service. Nothing happened, still same. I do NOT want to send this phone to Samsung Service, what should I do about this situation?

Some Details : My WiFi works very well, I can call other phones, I can send messages, I can recieve calls and messages, Only thing is Mobile Data So Slow and sometimes when I turned data on it says no signal for a while. Help Please !

EDIT: Stock 4.0.3 was only PDA file. It wasn't like 3-4 files to set into Phone section, Pit section... It was only PDA. At the moment I am using BeantStalk Rom 4.4.2 KitKat XXLPS Baseband.

Thanks in advance.
Regards.
 
MistahBungle
Old
#2  
Senior Member
Thanks Meter 3039
Posts: 6,724
Join Date: Nov 2011
If you'd posted this in a development thread, you likely would have copped a slap (and quite rightly). Dev threads are for development stuff, not for n00bs having
problems with connectivity.

It may not even be a phone side issue, it could easily be carrier-side. Having said that, you need to try different modems. Plenty of CWM flashable modem packages on XDA you can try. Start with the modems bundled with stock roms released by your carrier (you can check these at Samfirmware, if you click to download a stock rom, it will tell you the baseband, you can then find CWM versions of these modems on XDA), test, if no better--->>> then try modems bundled with stock roms released by other carriers in your country, test, if no better--->>>then try other modems bundled with stock roms released by other carrier in other countries.
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Probably the best thread ever posted on XDA
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
Donate to you ?? Bahahaaaaahahahahahahaaahahaha !!!
The Following User Says Thank You to MistahBungle For This Useful Post: [ Click to Expand ]
 
teror300
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 9
Join Date: Jun 2012
Thanks for the suggestion, today something strange happened and the signal "thing" started working somehow and i can use mobile network, but after phone calls it just disconnects for a while then reconnects again. It doesn't look so annoying so I will deal with it for a while. If it gets so annoying or goes into some crashes and other stuff I can apply what you have suggested.

I read some articles that saying XXLPS Basebands are actually not that well, If I try any other modem/baseband "thing", will it brick or something ? Or can i use 4.1.2 or 4.2.2 modem on KitKat ?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes