Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,915 Members 42,882 Now Online
XDA Developers Android and Mobile Development Forum

Soft bricked phone after downgrading ROMS. Can't flash in odin

Tip us?
 
KingRaaa
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Default Soft bricked phone after downgrading ROMS. Can't flash in odin

Hi,
About two weeks ago I updated my Samsung Galaxy S II to the latest nightly build of Cyanogenmod (through the updates part of the phone). Unfortunately I do not remember the build number of the nightly I updated to - but it must have been near 2014/04/07 (7th april 2014). It made quite a few things not work (It still worked as a phone), so I decided to downgrade to the latest stable build. (Again usint the updater built into the phone)
Now when I turn on my phone, the Samsung Galaxy S II screen comes up. Then it changes to the Cyanogenmod rotating circles boot animation, and stays on that boot animation.
I cannot access recovery mode.
I could not access download mode - but I got a jig and now I can. However when i connect my device in download mode to odin 3 v1.83 to flash it to stock the following error message appears: "USB Device Not Recognised. One of the USB devices attached to the computer has malfunctioned, and Windows dows not recognise it. For assistance in solving this problem, click this message."
I installed the samsung drivers from kies, then uninstalled kies but not the drivers. I disabled my antivirus.I do NOT have the android SDK installed.
Does anyone have any advice on how I can fix my phone?

Summary:
I rooted the device and installed cm 10.1 a while ago - my custom recovery was CWM
I got a notification that a nightly update was available
I updated to the nightly using the updater built into the phone. That was my only update since i installed cm 10.1. (Nightly was from about 7th April 2014 - not exacty sure)
It worked fine as a phone, but some functions didnt work.
I went back into the built-in updater and chose to DOWNgrade to the latest stable version.
When I turn on the phone now the Samsung Galaxy S II screens appears.Then the cm rotating boot animation appears.
The cm boot animation doesnt stop and the phone doesnt turn on
If I try to enter recovery or download mode using the buttons, it goes to the Galaxy S II screen then the cyanogen boot screen - same as if I wasnt pressing buttons
I bought a Jig which I can use to access download mode.
I have the drivers installed on my computer however I still get an error when trying to connect my phone in download mode to ODIN, which prevents me from flashing stock or recovery.
My other phone works fine when connecting to odin on the same computer

Any help in fixing this is appreciated. cheers
 
MistahBungle
Old
#2  
Senior Member
Thanks Meter 3205
Posts: 7,088
Join Date: Nov 2011
Your only option in this situation is Hopper 8's 'Odin troubleshooting' thread stickied in General. Try everything in that thread as many times as you need to in order to get a successful flash.

One thing stands out in what you've said though...

The errors about USB malfunctions/etc may also mean the USB board/port on the phone is on the way out. If you spend a few days trying the stuff in Hopper's thread & still can't get a successful flash (BTW, this is the only way you're fixing it, there isn't anything not in that thread which can be suggested in these situations), I'd replace the USB board/port. KeithRoss39 has a guide in General (not stickied; search for 'replace USB charger board' or do an advanced search on his username) which will enable you to do this yourself quickly/easily/cheaply (<US$15). The boards don't normally die completely, and often only exhibit a few faults while otherwise working OK. What you've described (not being able to get a successful flash, connection errors/problems) may well be the board malfunctioning.
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
The Following 3 Users Say Thank You to MistahBungle For This Useful Post: [ Click to Expand ]
 
Hopper8
Old
#3  
Hopper8's Avatar
Recognized Contributor
Thanks Meter 2166
Posts: 1,769
Join Date: Sep 2012
Quote:
Originally Posted by MistahBungle View Post
..KeithRoss39 has a guide in General (not stickied; search for 'replace USB charger board' or do an advanced search on his username) which will enable you to do this yourself quickly/easily/cheaply (<US$15)....
There's also a link to Keith's guide in my troubleshooting thread
The Following 3 Users Say Thank You to Hopper8 For This Useful Post: [ Click to Expand ]
 
KingRaaa
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Thanks for the advice. I'll try out the odin troubleshooting thread and replace my micro USB connector part if that doesn't work.
 
keithross39
Old
(Last edited by keithross39; 21st April 2014 at 02:41 AM.)
#5  
keithross39's Avatar
Senior Member
Thanks Meter 1183
Posts: 1,967
Join Date: Aug 2012
Location: Oxford
I'd be tempted to do things the other way around......if your port IS faulty, and it fails during an Odin flash, it is likely to kill your phone permanently. As @MistahBungle says, the part is cheap and easy to fit.....certainly cheaper than a new motherboard which will be your only alternative if the port fails during the flash

Sent from my Markox powered KitKatted S2
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes