Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,283 Members 38,497 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] Data gone yet memory full after spontaneous reset

Tip us?
 
WerKKill
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: May 2007
Default [SOLVED] Data gone yet memory full after spontaneous reset

The other day the phone seems to have just reset itself without user interaction. All apps and contacts and such are gone but the device memory is full (10mb free after clearing cache and doing delete dumpstate/logcat). The phone memory was also quite full before this happened. Before I perform a factory reset I wanted to ask if it's possible that the data is still there and could be recovered by rooting the phone or something.

Are the chances of recovering anything so low I might as well just do the reset? I'm also worried that the the low amount of available memory is a problem with rooting - is this a valid concern?

The phone is an GT-I9100 with stock Android 4.1.2 (not rooted)

Thanks in advance
 
WerKKill
Old
(Last edited by WerKKill; 4th June 2014 at 01:00 AM.)
#2  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: May 2007
So I rooted the phone and can now access the data on the phone using adb. However, I don't know how to copy e.g. the data folder to my computer or the usb memory because "cp" isn't recongnized and I'm not able to install busybox (or a file explorer) on the phone because of insufficient memory. I also can't seem to use adb pull to get the folders (adb pull /data/data outputs "0 files pulled, 0 files skipped").

EDIT: /data/lost+found seems to be taking all the space and looks like the lost data is there. After deleting some files I was able to install busybox and copy the folder where I can access it.

EDIT2: I indeed seem to be able to restore the data (so far tried with mini diary and was succesful) so I'll mark this as solved.
 
cowbutt
Old
#3  
Senior Member
Thanks Meter 49
Posts: 193
Join Date: Feb 2010
If you've got files in lost+found, they're there because the on-boot filesystem check, fsck, put them there because it found the filesystem to be corrupt. Best thing is to factory wipe as there may still be lurking errors. If it keeps happening, your phone's flash is probably defective (either worn out from use, or manufactured that way) like that in my i9100.

Sent from my Nexus 7 using Tapatalk
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes