FORUMS

Android 5.1 for the Nvidia Shield Tablet is Out!

Nvidia is quite good at delivering updates in a timely fashion. The producer of famous … more

Other than XDA (of Course), What’s Your Favorite Site That Covers Android?

There is a number of other great sites that cover … more

Introducing Voices of XDA: Have Your Ideas Heard

By far the greatest assets we have at XDA-Developers are you, the developers, the eager … more

Unofficial Xposed For Lollipop Touchwiz With Flashable Zip

XDA Recognized Developer arter97 has released an unofficial build … more
Post Reply Subscribe to Thread Email Thread

[Q] Voice calls

21st April 2012, 06:45 AM |#1  
OP Junior Member
Thanks Meter: 0
 
More
Im unable to make voice calls through the Phone app. It will connect, then make no noise (ie no ringing). Same if i receive a call, i hit accept and i hear nothing, nor can the person calling me hear anything. I can use the voice search/navigation, and i can use other voice apps (ie voxer) just fine. SMS works, as does 3g, and im not getting any error messages.

Phone is GT-I9100, Kernel is Siyah 3.1rc6, running D4rom (ICS). I've tried 3 seperate roms (Omega v11, D4, and Slim (all ICS)) all having the same issues. Im assuming this is an issues with ICS (or more likely something i didnt update prior to switching) but ive spent about 6 hours now trying to find out what is causing it.

I realize downgrading would solve this, but i'd rather find out what my issue is and fix it. any ideas?
 
 
21st April 2012, 07:15 AM |#2  
Account currently disabled
Flag Iraq
Thanks Meter: 462
 
More
Flash again, but this time full wipe, it happened to me once on d4 rom, this should do it
21st April 2012, 07:15 AM |#3  
Senior Member
Flag Phuket, Thailand
Thanks Meter: 6,433
 
More
Edit: have you tried wanamlite with siyahkernel? If you follow the below, you shouldn't have a problem.

A. Ensure FULL wipe;
1. System
2. Cache
3. Data
4. Dalvik cache

B. Immediately Flash ROM
C. Let boot and initial setup
D. Check if phone dialer and choice calls are ok?
E. If ok, Restore only user apps and data. NO System crap. Recheck
F. Reboot and setup accounts. Recheck

Sent from my GT-I9100 using xda premium
21st April 2012, 11:01 PM |#4  
OP Junior Member
Thanks Meter: 0
 
More
Still no luck. Flashed 3 times, once with D4 again, twice with wanalite. did factory reset, manually wiped /data, /system, /cache, and Dalvik cache. after doing initial run (i didn't set up my gmail account, since i need wifi for that (data cap is annoying)) i tried to make a call, and it still wont ring. At first it would end the call after 15's or so. after restarting it it would go longer, usually until i end it. SMS still works, as does 3g data.

I got an error this time setting up the clock, but it was only visible for about 2s. It was something to do with setting the time, if i can get it again ill try to write it down.

Also, when wiping the Dalvik cache i get this :
E:unknown voluem for path [/sd-ext]
Dalvik cache wiped

any other advice?
21st April 2012, 11:44 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
I finally downgraded to GB rom (unnamed). Phone worked fine, as well as everything else. Ty for your help though, It was greatly appreciated.

Also, i noticed prior to updating it that the search and back buttons didnt do anything. IDK if this is normal or not, i dont use those buttons much.
22nd April 2012, 12:51 AM |#6  
Senior Member
Flag Phuket, Thailand
Thanks Meter: 6,433
 
More
Very strange after fresh full wipe and flash, and test without setup of the different ROMs

Edit: Have you tried flashing some of the alternative ICS modems found in the modem thread? Maybe yours doesn't like the modem packaged with the ROM.

If that doesn't work, what if you flash one of Intratech official or Frankenstein firmware. You'll need to re-root after and flash cwm again.

That error with the Dalvik is ok. Forget why, answer will be found with some searching though. If you look carefully, it would have said "Dalvik cache wiped"

Sent from my GT-I9100 using xda premium
Last edited by UpInTheAir; 22nd April 2012 at 01:04 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes