Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Exclamation [Q] 3G connection but no calls/sms working (Solved)

OP samadroid

31st July 2013, 01:24 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Nov 2010
Hi everybody,

I have been forced to open this thread because of a curious and, as It seems by the searches I made, quite rare problem affecting the network capability of my GT-i9100.

Basically, the phone won't make calls nor send sms (saying that It is "not registered on network"), but at the same time It will be perfectly capable of connecting to the internet (browsing the web, navigating the Playstore, using Whatsapp, ecc..) through 3G network.
Looking in Settings>About device>Status, It shows to be regularly connected to my mobile carrier, even though "Service state" is "Out of service".
Even if I try to manually select the network operator from Settings>Mobile Networks It says "Unable to connect".

I've first tried to verify the carrier network functioning by moving the sim card to another phone (which works perfectly) then, thinking It was fault of the Cyanogenmod I was running (cm-10.1-20130728-NIGHTLY-i9100), I've brought the phone back to complete stock (PDA: I9100XWLSW,
CSC: I9100ITVLS2, MODEM: I9100XXMS3) and made a full wipe, without any positive results.

At this stage I have to say I'm getting a bit put out and, having to fly abroad in two days, desperate for solutions. Any idea?

Thanks a lot in advance.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-07-31-01-16-57.jpg
Views:	115
Size:	22.0 KB
ID:	2153953   Click image for larger version

Name:	Screenshot_2013-07-31-01-17-50.jpg
Views:	88
Size:	26.0 KB
ID:	2153954   Click image for larger version

Name:	Screenshot_2013-07-31-01-17-26.jpg
Views:	95
Size:	11.7 KB
ID:	2153955  
Last edited by samadroid; 31st July 2013 at 04:09 PM.
31st July 2013, 02:34 AM   |  #2  
andrewwright's Avatar
Senior Member
Thanks Meter: 3,124
 
5,521 posts
Join Date:Joined: Feb 2013
Donate to Me
More
Check apns and imei mate common fault after flashing things is loss of imei. Have a look. Reset apns and see if it works. Next question...did you Bk up your efs Folder? If not lets hope your imei is ok
31st July 2013, 09:29 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by andrewwright

Check apns and imei mate common fault after flashing things is loss of imei. Have a look. Reset apns and see if it works. Next question...did you Bk up your efs Folder? If not lets hope your imei is ok

Tried to reset apn settings but no results. Checked the Imei and It displays the number you see in the attachment, but I don't know if it's any different from the original.
As for the EFS folder, I've got a copy of It in my sdcard. I guess it counts as backup. But are you suggesting to restore it?

I can't still understand how, if there is something wrong with network settings, I can't make nor receive calls and messages but I can normally use my data plan to connect to the Internet and follow this thread from my Galaxy.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-07-31-09-04-47.jpg
Views:	96
Size:	22.3 KB
ID:	2154704  
31st July 2013, 10:13 AM   |  #4  
andrewwright's Avatar
Senior Member
Thanks Meter: 3,124
 
5,521 posts
Join Date:Joined: Feb 2013
Donate to Me
More
What you have is the test imei from samsung. Restore it pls. With test imei 00000bla bla you can use data but no calls or texs which is what is happening to you. Some country networks let you make calls with this imei. But not yours. Can I ask what network and country your from. Just for my info :thumbup:
The Following User Says Thank You to andrewwright For This Useful Post: [ View ]
31st July 2013, 10:34 AM   |  #5  
OP Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by andrewwright

What you have is the test imei from samsung. Restore it pls. With test imei 00000bla bla you can use data but no calls or texs which is what is happening to you. Some country networks let you make calls with this imei. But not yours. Can I ask what network and country your from. Just for my info :thumbup:

"I TIM" network from Italy. I'm gonna try and let you know the hesit. Thanks for your time
31st July 2013, 01:56 PM   |  #6  
OP Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Nov 2010
Thumbs up
That's It I've just copied and pasted the original EFS folder into root, wiped cache and rebooted the phone; and It works flawlessly.
Thanks a lot for your kind help
The Following User Says Thank You to samadroid For This Useful Post: [ View ]
31st July 2013, 03:46 PM   |  #7  
andrewwright's Avatar
Senior Member
Thanks Meter: 3,124
 
5,521 posts
Join Date:Joined: Feb 2013
Donate to Me
More
No problem. Glad its sorted. Put solved on thread title pls :thumbup:
5th July 2014, 09:53 PM   |  #8  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Sep 2008
Quote:
Originally Posted by andrewwright

No problem. Glad its sorted. Put solved on thread title pls :thumbup:

hello i don't find efs folder where is it exactly please?i have the same problem only data and no calls or text msg
i have an htc one m8

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes