Early Lollipop Ports for Micromax A116 and A117

It feels like it was only yesterday when Google announced the mysterious Android L.After … more

Now Gesture Tweaks Replaces Google Now with Custom Action

On most modern Android devices with software navigation keys, swiping up from the … more

ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Whattsapp/Telegram/Hanghouts dont arrive while screenoff (kitkat rom)

OP velocity90

20th May 2014, 05:08 PM   |  #1  
OP Senior Member
Thanks Meter: 206
 
634 posts
Join Date:Joined: Apr 2013
Hi,

I searched a lot about this problem. A lot seem to have this problem with Kitkat roms but I have yet to find a solution. Whattsapp, telegram, hangouts and email also dont arrive when screen is off. I have wifi set to Always on.

I tried Neatrom AOSP and Slimsaber, they both have the same problem (same source) On JB this problem wasnt there. Tried everything from changing kernels to wiping caches, complete wipes and installs. Fresh install of whattsapp, all does nothing to the problem. If I turn on and unlock my Phone messages will arrive, sometimes after 1 minute.

Push notifier app doesnt work, tried it already. I havent greenified those apps. And have reflashed at least more than 10 times. Complete wipes and fresh download of whattsapp. I can see in my router that my Phone keeps its connection during sleep.

Both wifi and 3g tiles are orange most of the time, thats also weird. Some say its like that but Ive checked some phones and they dont do that.
Last edited by velocity90; 20th May 2014 at 05:24 PM.
20th May 2014, 05:33 PM   |  #2  
banjara's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 115
 
419 posts
Join Date:Joined: Mar 2014
More
I had tried multiple KK roms and sometimes I faced the same issue. In my case it was a custom kernel(dori/gustavo/appollo - I dont remember which one) which changed the deep sleep behaviour of the device. Never faced the same issue with stock kernel of that KK rom.
Are you on custom kernel too?
20th May 2014, 05:36 PM   |  #3  
OP Senior Member
Thanks Meter: 206
 
634 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by banjara

I had tried multiple KK roms and sometimes I faced the same issue. In my case it was a custom kernel(dori/gustavo/appollo - I dont remember which one) which changed the deep sleep behaviour of the device. Never faced the same issue with stock kernel of that KK rom.
Are you on custom kernel too?

Now apolo light, tried stock neatrom, , dori, gustavo

Im just flashed the newest Slimsaber so I can see if the problem is there with stock slimsaber kernel
20th May 2014, 06:03 PM   |  #4  
FPSUsername's Avatar
Senior Member
Thanks Meter: 296
 
1,672 posts
Join Date:Joined: Jun 2012
Donate to Me
More
I don't have any problems on carbon + dori
20th May 2014, 06:30 PM   |  #5  
OP Senior Member
Thanks Meter: 206
 
634 posts
Join Date:Joined: Apr 2013
On dori I had, also freezes and lag v112

What I could find that its a problem with Motorola based kitkat (first kitkat so a lot of roms)
20th May 2014, 06:32 PM   |  #6  
OP Senior Member
Thanks Meter: 206
 
634 posts
Join Date:Joined: Apr 2013
On dori I had, also freezes and lag v112

What I could find that its a problem with Motorola based kitkat (first kitkat so a lot of roms)

I cant say if its solved with stock kernel, tonight it will be quiter on whattsapp and easier to spot.
21st May 2014, 11:01 AM   |  #7  
OP Senior Member
Thanks Meter: 206
 
634 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by banjara

I had tried multiple KK roms and sometimes I faced the same issue. In my case it was a custom kernel(dori/gustavo/appollo - I dont remember which one) which changed the deep sleep behaviour of the device. Never faced the same issue with stock kernel of that KK rom.
Are you on custom kernel too?

Stock Slimsaber kernel seems to have fixed it. Will give it 2 more days to be sure. Too bad, because Apolo gives me the best performance and battery
21st May 2014, 11:15 AM   |  #8  
banjara's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 115
 
419 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by velocity90

Stock Slimsaber kernel seems to have fixed it. Will give it 2 more days to be sure. Too bad, because Apolo gives me the best performance and battery

I am glad that I could point you in the right direction even if I am a noob
because of the deep sleep troubles only I had to come out of dori.

The Following User Says Thank You to banjara For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes