5,596,128 Members 33,873 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Wireless N on SGS2?

Tip us?
 
wind79
Old
#1  
Member - OP
Thanks Meter 1
Posts: 41
Join Date: Apr 2009
Question [Q] Wireless N on SGS2?

Hi guys, anyone can help me out here with regards to connecting our SGS2 to Wireless N network? I have tried changing my radio frequency setting and even resorted to using WEP authentication instead of WPA, but I just can't get the phone to connect via N network, it always connects via G instead. But under the same settings, I am able to connect my acer laptop and my wife's iphone4 to the N network.

Is there any specific settings I need to configure on my router? I am using a Prolink H5004N adsl2+ modem with wireless N router. The modem is compliant to IEEE 802.11n standards, not draft-n and should work with the SGS2?
HTC Touch HD (T828X)
HTC HD2 (T8585)
Samsung Galaxy S (GT-I9000)
Samsung Galaxy S2 (GT-I9100)
Samsung Galaxy S3 (GT-I9300)
Samsung Galaxy S4 (GT-9505)
HTC One (M7UL)
 
mljjlm
Old
#2  
Senior Member
Thanks Meter 68
Posts: 379
Join Date: Mar 2010
Location: Copenhagen

 
DONATE TO ME
Quote:
Originally Posted by wind79 View Post
Hi guys, anyone can help me out here with regards to connecting our SGS2 to Wireless N network? I have tried changing my radio frequency setting and even resorted to using WEP authentication instead of WPA, but I just can't get the phone to connect via N network, it always connects via G instead. But under the same settings, I am able to connect my acer laptop and my wife's iphone4 to the N network.

Is there any specific settings I need to configure on my router? I am using a Prolink H5004N adsl2+ modem with wireless N router. The modem is compliant to IEEE 802.11n standards, not draft-n and should work with the SGS2?
Not sure, but I think that it will connect if your N-network are in the 2.4 GHz frequency area, but not in the 5.0 GHz
 
wind79
Old
#3  
Member - OP
Thanks Meter 1
Posts: 41
Join Date: Apr 2009
Quote:
Originally Posted by mljjlm View Post
Not sure, but I think that it will connect if your N-network are in the 2.4 GHz frequency area, but not in the 5.0 GHz
Yup, tried that too, but still connects to G only. I have also tried configuring router to accept only N networks instead of G/N, but then the SGS2 will not even see the SSID when its performing a wireless scan.
HTC Touch HD (T828X)
HTC HD2 (T8585)
Samsung Galaxy S (GT-I9000)
Samsung Galaxy S2 (GT-I9100)
Samsung Galaxy S3 (GT-I9300)
Samsung Galaxy S4 (GT-9505)
HTC One (M7UL)
 
grey77
Old
(Last edited by grey77; 14th July 2011 at 02:56 AM.)
#4  
Member
Thanks Meter 14
Posts: 44
Join Date: May 2011
Location: Moscow
Quote:
Originally Posted by wind79 View Post
connecting our SGS2 to Wireless N network?
Ive got the same issue. Router Asus RT-N16 (b/g/n, 2.4GHz). Playing with different router firmwares, settings and so on - no luck so far.
 
knightnz
Old
#5  
Senior Member
Thanks Meter 240
Posts: 1,569
Join Date: Dec 2009
Location: Wellington

 
DONATE TO ME
Check the "advanced" settings by pressing the menu button in the wireless and make sure nothing wierd is set in there.

Otherwise, as long as the router is set to N only on the 2.4ghz band, it should at _least_ see the SSID.

That modem supports WPS, try pressing the WPS button on the back of the modem and then use the "WPS button connection" option in the wi-fi settings menu on the SGS2.

Remember the single-channel 802.11n 2.4ghz such as the SGS2 supports will only max out at 72mbps anyway so there's not a huge improvement over the 54mbps that 11g will give you, although 11n is more efficient.
---

Spelling essentials:
1) There is NO SUCH WORD as "alot" - It's "a lot"
2) The shortened form of You are is You're - NOT Your
3) Loosing & Loose have completely different meanings to Losing & Lose.
The Following User Says Thank You to knightnz For This Useful Post: [ Click to Expand ]
 
knightnz
Old
#6  
Senior Member
Thanks Meter 240
Posts: 1,569
Join Date: Dec 2009
Location: Wellington

 
DONATE TO ME
Quote:
Originally Posted by grey77 View Post
Ive got the same issue. Router Asus RT-N16 (b/g/n, 2.4GHz). Playing with different router firmwares, settings and so on - no luck so far.
I've got the same unit and it works fine with it, that said I'm running a recent build of the Tomato firmware on mine. I don't think I even powered it up fully with the original firmware...
---

Spelling essentials:
1) There is NO SUCH WORD as "alot" - It's "a lot"
2) The shortened form of You are is You're - NOT Your
3) Loosing & Loose have completely different meanings to Losing & Lose.
 
grey77
Old
#7  
Member
Thanks Meter 14
Posts: 44
Join Date: May 2011
Location: Moscow
Quote:
Originally Posted by knightnz View Post
Check the "advanced" settings by pressing the menu button in the wireless and make sure nothing wierd is set in there.

Otherwise, as long as the router is set to N only on the 2.4ghz band, it should at _least_ see the SSID.
thx for fast reply
SGS2 can see SSID, but fails to connect until I force RT-N16 (with custom firmware, RT-N16-1.9.2.7-rtn-r3121) down to "Use 802.11 G only".
Never had any problems with other 802.11 N powered devices.
 
ndrsconschrtysvcs
Old
#8  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Nov 2013
Thumbs up only wpa2-aes or no encryption are N-standard

Quote:
Originally Posted by wind79 View Post
Hi guys, anyone can help me out here with regards to connecting our SGS2 to Wireless N network? I have tried changing my radio frequency setting and even resorted to using WEP authentication instead of WPA, but I just can't get the phone to connect via N network, it always connects via G instead. But under the same settings, I am able to connect my acer laptop and my wife's iphone4 to the N network.
wireless N only officially supports either WPA2-AES encryption or no encryption. Devices with drivers that more closely comply to the spec will not connect to WEP or WPA.

I hope you fixed the issue. I stumbled across this thread while asking the same question; maybe someone else will benefit by having this thread wrapped-up also. No haters, egos, persons, etc please. It's been necessary already to block a few of you.

Tags
802.11n, prolink, wireless
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes