Post Reply

[KERNEL] SpeedMod SGS2 [K2-21 CWM5 CIFS ROOT]

OP hardcore

26th July 2011, 02:01 PM   |  #231  
Senior Member
Thanks Meter: 4
 
129 posts
Join Date:Joined: Nov 2010
@hc:

nevermind, I just tried this 2.6.35.11 kernel and found out it has the same dual core problem. Obviously samsung fixed this somehow in current stock kernels (KG2/KG3).
26th July 2011, 02:57 PM   |  #232  
beppez82's Avatar
Senior Member
Flag Padua
Thanks Meter: 22
 
500 posts
Join Date:Joined: Jul 2010
More
Quote:
Originally Posted by russell.nash

@hc:

nevermind, I just tried this 2.6.35.11 kernel and found out it has the same dual core problem. Obviously samsung fixed this somehow in current stock kernels (KG2/KG3).

What do you mean for dual core problem?

Sent from my Speedmodded Villain SGS 2
26th July 2011, 03:00 PM   |  #233  
Senior Member
Flag Perm
Thanks Meter: 38
 
159 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by russell.nash

@hardcore

Nice to see you here :)
there is a dual core issue in the kernel source you are using. some apps (games) crash or freeze with this kernel version. the issue is fixes with samsung kernel KG2. .

I think the issue is not fixed in KG2 kernel. I have some crashes and freezes with it too..


Quote:
Originally Posted by beppez82

What do you mean for dual core problem?

Issue: http://code.google.com/p/android/issues/detail?id=17623
Workaround: Turn Off sound in such games/apss -> then it runs without any freezes
Last edited by DimICE; 26th July 2011 at 03:05 PM.
26th July 2011, 03:15 PM   |  #234  
Senior Member
Thanks Meter: 4
 
129 posts
Join Date:Joined: Nov 2010
The problem was very frequent on KE4/7 for me. On KFx it got better but was not gone, since KGx I cannot reproduce it any longer. I have no idea if it is really a sound issue. It feels like a code deadlock, since CPU is getting very hot sometimes it happens...

EDIT: I cannot confirm that this is a sound issue. Even with sound off the problem can be produced.
Last edited by russell.nash; 26th July 2011 at 03:37 PM.
26th July 2011, 03:26 PM   |  #235  
reidar.ostrem's Avatar
Senior Member
Flag Sandnes
Thanks Meter: 45
 
643 posts
Join Date:Joined: Sep 2006
More
Quote:
Originally Posted by beppez82

I'm using vr 2.1 nothing strange btw I'm using a static ip and maybe that make the difference

Sent from my Speedmodded Villain SGS 2

That may be the difference The problem is that the connection is hanging while getting ip from the DHCP server ...
26th July 2011, 03:45 PM   |  #236  
Senior Member
Flag Perm
Thanks Meter: 38
 
159 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by russell.nash

The problem was very frequent on KE4/7 for me. On KFx it got better but was not gone, since KGx I cannot reproduce it any longer. I have no idea if it is really a sound issue. It feels like a code deadlock, since CPU is getting very hot sometimes it happens...

EDIT: I cannot confirm that this is a sound issue. Even with sound off the problem can be produced.

With sound off in options in game (not with volume down button) problem can be reproduced??
26th July 2011, 04:22 PM   |  #237  
Senior Member
Thanks Meter: 4
 
129 posts
Join Date:Joined: Nov 2010
The only way I found to prevent the problem is using a stock kernel > KG1. If you flash CF-Root KG3 to name an example my problem is gone. CF is a pure stock kernel with several script addons.
26th July 2011, 04:39 PM   |  #238  
Locster126's Avatar
Senior Member
LONDON
Thanks Meter: 54
 
385 posts
Join Date:Joined: Feb 2011
More
Been using this kernel for two days. Battery seems similar to stock kernel but i don't like the fact that logcat and dmesg is disabled and lastly that things like android os are hidden in battery stats. I do like to know what's going on in the background on my phone.....

Sent from my GT-I9100 using Tapatalk
26th July 2011, 04:59 PM   |  #239  
Senior Member
Thanks Meter: 37
 
403 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by eybee1970

Then flash cf root kg2 with odin on your rom...afterwards you have cwm and can flash this kernel as i described

Thanks for the tip. I tried this method but now my recovery is 3E and I seem to have lost 2E.
26th July 2011, 05:14 PM   |  #240  
Junior Member
Thanks Meter: 2
 
28 posts
Join Date:Joined: Mar 2011
Aww man.. I tried flashing to speedmod k1-t8 but was unsuccessful.

I had flashed kernel under cwm from KF1 to KG3. This part was successful.

Thereafter, opened up Odin, click speedmod under PDA with phone connected by it showed unsuccessful.. anyone know what I missed?

Post Reply Subscribe to Thread

Tags
kernel, speedmod
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S II Original Android Development by ThreadRank