Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[MOD] Android Browser Arabic Shaping Patch and Hebrew RTL Fix v3.93B (14, May 2013)

OP brightidea

16th August 2011, 08:30 AM   |  #21  
Tricky103's Avatar
Recognized Developer
Flag Exeter, UK
Thanks Meter: 747
 
3,405 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Quote:
Originally Posted by abu2x

hi brightidea,
I've done your way, but there produce libwebcore.so.bak instead of libwebcore.so
can i use this and just delete .bak?

Thank you.

Did you go to command prompt and run the program? On windows 7 it asks for permission. Please say what rom your using then maybe someone can upload the files for you


Sent from my GT-I9100 using Tapatalk
16th August 2011, 10:12 AM   |  #22  
Senior Member
Thanks Meter: 4
 
130 posts
Join Date:Joined: Oct 2007
I have arabic in browser and and in email, but I lost in documents to go. I had arabic for it before. You guys know the reason?

Sent from my PG41200 using Tapatalk
16th August 2011, 11:09 AM   |  #23  
brightidea's Avatar
OP Senior Member
Flag Heart of Arabian Peninsula
Thanks Meter: 227
 
225 posts
Join Date:Joined: May 2011
Donate to Me
More
Quote:
Originally Posted by Mouaz10

Still don't work with Twitter (the app)
GSII DarkyRom2 KG6 Base3.2

To enable arabic in the Twitter APP you need to apply madmack's patch to framework.jar check http://forum.xda-developers.com/show....php?t=1063205

My patch only enables arabic shaping in the browser - try twitter in the browser

- Brightidea
The Following User Says Thank You to brightidea For This Useful Post: [ View ]
16th August 2011, 11:10 AM   |  #24  
brightidea's Avatar
OP Senior Member
Flag Heart of Arabian Peninsula
Thanks Meter: 227
 
225 posts
Join Date:Joined: May 2011
Donate to Me
More
Quote:
Originally Posted by bobster0001

I have arabic in browser and and in email, but I lost in documents to go. I had arabic for it before. You guys know the reason?

Sent from my PG41200 using Tapatalk

My patch should not affect anything but the browser - If you believe it caused issues with Documents To Go then revert to the original libwebcore.so to make sure

- Brightidea.
16th August 2011, 12:22 PM   |  #25  
Member
Thanks Meter: 1
 
35 posts
Join Date:Joined: Aug 2010
Yes, the browser is Full Arabic, Opera too
I try the other patch, before applying your patch, then I apply your patch => Twitter app still not arabic
I have reinstall the DarkyRom2 KG6
Then I have apply you patch at first the the other, but twitter still don't write arabic
16th August 2011, 01:12 PM   |  #26  
brightidea's Avatar
OP Senior Member
Flag Heart of Arabian Peninsula
Thanks Meter: 227
 
225 posts
Join Date:Joined: May 2011
Donate to Me
More
Quote:
Originally Posted by Mouaz10

Yes, the browser is Full Arabic, Opera too
I try the other patch, before applying your patch, then I apply your patch => Twitter app still not arabic
I have reinstall the DarkyRom2 KG6
Then I have apply you patch at first the the other, but twitter still don't write arabic

Twitter APP is not affected by my patch - check Madmack's patch. I assure you I have DarkyROM KG6 and twitter displays arabic perfectly.

- Brightidea.
16th August 2011, 07:23 PM   |  #27  
Senior Member
Thanks Meter: 20
 
784 posts
Join Date:Joined: Oct 2007
Quote:
Originally Posted by abu2x

hi brightidea,
I've done your way, but there produce libwebcore.so.bak instead of libwebcore.so
can i use this and just delete .bak?

Thank you.

i have the same problem.

i am using this ROM http://forum.xda-developers.com/show....php?t=1220283

and i have attached the libwebcore file.
Attached Files
File Type: zip libwebcore.zip - [Click for QR Code] (20.4 KB, 29 views)
16th August 2011, 08:47 PM   |  #28  
wanam's Avatar
Recognized Contributor / Developer
Flag Temara
Thanks Meter: 22,004
 
4,841 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Thumbs up
Tested your beta2 for Villain Rom 2.4.2, working now with out any issues.

Good job BrightIdea
16th August 2011, 10:59 PM   |  #29  
Senior Member
Thanks Meter: 33
 
118 posts
Join Date:Joined: Jul 2010
Donate to Me
More
Great work Brightidea!!!

The patch is being tested for all MIUI supported devices. Will give more feedback soon as it's fully tested in as more different devices as possible.

MIUI Users are welcome to use the flashable ZIP I posted in my thread.
http://forums.miuiandroid.com/showthread.php?723
The Following User Says Thank You to roenano For This Useful Post: [ View ]
16th August 2011, 11:52 PM   |  #30  
Senior Member
Thanks Meter: 4
 
130 posts
Join Date:Joined: Oct 2007
Quote:
Originally Posted by brightidea

My patch should not affect anything but the browser - If you believe it caused issues with Documents To Go then revert to the original libwebcore.so to make sure

- Brightidea.

Yeah you are right. It is actually the framework. Do you know what the problem is? Before the patch, documents to go had arabic for some reason and everything else didn't. But after the framework patch, document to go lost its arabic and everything else have arabic

Sent from my GT-I9100 using Tapatalk
Last edited by bobster0001; 16th August 2011 at 11:56 PM.

Post Reply Subscribe to Thread

Tags
arabic, browser, hebrew, patch, shaping
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes