Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Modem][Baseband]4.4.2 Modems for I747/I747M

OP DocHoliday77

30th December 2014, 03:45 AM   |  #51  
Senior Member
Thanks Meter: 84
 
255 posts
Join Date:Joined: Nov 2013
More
Quote:
Originally Posted by canodroid15

I don't think so, I updated mine & I didn't. I run my d2att on straight talk!

I don't know the answer to the original question re: losing carrier unlock, but I don't believe, from what I have read, that Straight Talk ever required carrier unlock.
30th December 2014, 04:01 AM   |  #52  
Quote:
Originally Posted by bloodstorm666

Just finished updating to NE4!! Now, how did you get to NJ1?

Checkout this thread, this is where I got all my info & zip links: http://forum.xda-developers.com/show....php?t=2941792
I think you can just flash NJ1, however I'm not 100% sure I've heard that you need to be on 4.4.2 OTA to flash NJ1 & I've also heard people say they flashed NE4 & then NJ1. I was on NE4 stock OTA when I went to NJ1, just ask enewman17 to be sure he really knows his stuff! If he says you're good then go for it!

---------- Post added at 03:01 AM ---------- Previous post was at 02:48 AM ----------

@bloodstorm666 here's another link for NJ1 info,
http://forum.xda-developers.com/show....php?t=2985006
Hope this helps man!
Last edited by canodroid15; 30th December 2014 at 03:52 AM.
15th January 2015, 03:32 AM   |  #53  
Member
Thanks Meter: 7
 
95 posts
Join Date:Joined: Nov 2009
Info 2
Hi everyone,

Could someone help me to clarify something that I'm not yet 100% sure please:

I was given a cracked-screen SGH-I747M Canada.
Its original (and currently) rom is: I747MVLUFNH2 4.4.2 stock (bell or virgin). <=== NH2
Rooted and recovery:TWRP 2.8.x.x latest.

I don't have a mini-sim card yet (I will cut the standard sim to mini-sim). It's a Rogers's sim.

1) My question is: Can I "cross" flash this phone by flashing a stock Rogers' rom ?

Since I don't want to pay to provider-unlock (I don't even know if the phone provider-locked). Danger of bricking ?

2) And I also notice on the 1st page that the modem for Rogers is Not NH2, but VLUFNF2 (NF2)

Can I overwrite NH2 (current modem) with NF2 ?

Thank you everybody.

Device Type: d2can
Build Description: d2vl-user 4.4.2 KOT49H I747MVLUFNH2 release-keys
Last edited by sintoo; 15th January 2015 at 03:35 AM.
15th January 2015, 04:54 AM   |  #54  
Quote:
Originally Posted by sintoo

Hi everyone,

Could someone help me to clarify something that I'm not yet 100% sure please:

I was given a cracked-screen SGH-I747M Canada.
Its original (and currently) rom is: I747MVLUFNH2 4.4.2 stock (bell or virgin). <=== NH2
Rooted and recovery:TWRP 2.8.x.x latest.

I don't have a mini-sim card yet (I will cut the standard sim to mini-sim). It's a Rogers's sim.

1) My question is: Can I "cross" flash this phone by flashing a stock Rogers' rom ?

Since I don't want to pay to provider-unlock (I don't even know if the phone provider-locked). Danger of bricking ?

2) And I also notice on the 1st page that the modem for Rogers is Not NH2, but VLUFNF2 (NF2)

Can I overwrite NH2 (current modem) with NF2 ?

Thank you everybody.

Device Type: d2can
Build Description: d2vl-user 4.4.2 KOT49H I747MVLUFNH2 release-keys

Don't try it, you will brick it!
22nd January 2015, 03:18 PM   |  #55  
Junior Member
Thanks Meter: 2
 
9 posts
Join Date:Joined: Dec 2014
Sorry for being a noob here, but I just want to make sure I do this right. I'm running a Rogers S3 and the bootloader I have is I747MVLUEMK5 and the modem is I747MUMUEND3 and I'm running CM11 (4.4.4). Can I go ahead and apply the modem in this thread? If not, I'm assuming I have to update the bootloader first, but I can't seem to find a download to just the bootloader. The I747MVLUFNF2 download on sammobile looks like it's going to put my phone back to stock, which isn't what I want if I don't have to because I prefer to use CM11. Thanks in advance.
28th January 2015, 12:18 AM   |  #56  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2012
Quote:
Originally Posted by cain05

Sorry for being a noob here, but I just want to make sure I do this right. I'm running a Rogers S3 and the bootloader I have is I747MVLUEMK5 and the modem is I747MUMUEND3 and I'm running CM11 (4.4.4). Can I go ahead and apply the modem in this thread? If not, I'm assuming I have to update the bootloader first, but I can't seem to find a download to just the bootloader. The I747MVLUFNF2 download on sammobile looks like it's going to put my phone back to stock, which isn't what I want if I don't have to because I prefer to use CM11. Thanks in advance.

I updated to the the latest Telus NK2 image on sammobile recently in order to ensure I was running the latest bootloader/modem for lollipop (was having issues on the mid-2013 bootloader/modem combo I had been running - and flashable bootloaders don't seem to be posted anymore). What I did, was 1) backup apps and make nandroid, 2) flash sammobile NK2 image through ODIN, 3) boot phone directly into download mode again and flash TWRP recovery, 4) boot into TWRP and flash the lollipop rom/GAPPs/SuperSU, 5) boot-up lollipop (first boot is sloooow) and restore apps. I got stuck in a boot loop at step 3 if I tried to actually boot back into the stock 4.4.2 rom, which is apparently fixed by wiping the internal card (something I was trying to avoid), but I was able to get around it just by flashing TWRP. Good luck if you go this route. I was ready to lose my phone to a brick, if needed, given all the caution about upgrading to recent bootloaders but thankfully it all worked out.
28th January 2015, 03:02 PM   |  #57  
Junior Member
Thanks Meter: 2
 
9 posts
Join Date:Joined: Dec 2014
Quote:
Originally Posted by thetenthday

I updated to the the latest Telus NK2 image on sammobile recently in order to ensure I was running the latest bootloader/modem for lollipop (was having issues on the mid-2013 bootloader/modem combo I had been running - and flashable bootloaders don't seem to be posted anymore). What I did, was 1) backup apps and make nandroid, 2) flash sammobile NK2 image through ODIN, 3) boot phone directly into download mode again and flash TWRP recovery, 4) boot into TWRP and flash the lollipop rom/GAPPs/SuperSU, 5) boot-up lollipop (first boot is sloooow) and restore apps. I got stuck in a boot loop at step 3 if I tried to actually boot back into the stock 4.4.2 rom, which is apparently fixed by wiping the internal card (something I was trying to avoid), but I was able to get around it just by flashing TWRP. Good luck if you go this route. I was ready to lose my phone to a brick, if needed, given all the caution about upgrading to recent bootloaders but thankfully it all worked out.

I was considering flashing the stock rom, but I seem to recall reading somewhere about the bootloader being locked with the recent updates. If that's the case, I think I'll just stick with what I have until something doesn't work and I have no choice but to try and upgrade. I don't think I'll be using a L build any time soon since there's problems with the camera, among other things.
Last edited by cain05; 28th January 2015 at 03:06 PM.
28th January 2015, 09:19 PM   |  #58  
Senior Member
Thanks Meter: 84
 
255 posts
Join Date:Joined: Nov 2013
More
Quote:
Originally Posted by cain05

I was considering flashing the stock rom, but I seem to recall reading somewhere about the bootloader being locked with the recent updates. If that's the case, I think I'll just stick with what I have until something doesn't work and I have no choice but to try and upgrade. I don't think I'll be using a L build any time soon since there's problems with the camera, among other things.

Is it locked or are we just not able to downgrade.
I thought a locked bootloader referred to being unable to root and/or install unsigned packages.
Yesterday, 02:36 PM   |  #59  
Junior Member
Thanks Meter: 2
 
9 posts
Join Date:Joined: Dec 2014
Quote:
Originally Posted by dawgdoc

Is it locked or are we just not able to downgrade.
I thought a locked bootloader referred to being unable to root and/or install unsigned packages.

I believe a locked bootloader prevents you from installing stuff like CWM, which would then prevent me from going into recovery and loading CM11 back on after upgrading to stock. All I want to do is make sure my bootloader and modem are the latest versions. If I can flash the firmware from sammobile then restore my CM11 install from a backup made in CWM that's all I need. I can't risking bricking my phone, which is why I'm trying to figure this out beforehand.
Today, 12:37 AM   |  #60  
Member
Thanks Meter: 3
 
39 posts
Join Date:Joined: Apr 2011
More
I've got a Bell SGH-i747M which I installed CM11 on using the CM Installer.
11-20141112-SNAPSHOT-M12-d2lte
Android 4.4.4
Baseband VLUFNH2

Things are working fine, however there have been a few times when I've experienced a loss of mobile data despite having a strong signal. It would work in one part of the city then an hour later in another part, I'd have no data.

I'm now wondering if I need to upgrade the modem?
I see from this thread that there are two versions for Bell: VLUFNE6 and VLUFNH2
Which one is newer? Do I need to upgrade the modem?

Post Reply Subscribe to Thread

Tags
baseband, modem, ne4, ne6, nf2
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes