Post Reply

[Q] Help troubleshooting soft resets. Possible firmware problem.

OP xshadowinxbc

28th August 2014, 10:49 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Nov 2012
These are the two setups I have used thus far (besides full stock), and this issue has occurred on both:
http://imgur.com/EgzxWFI
http://imgur.com/FZWrdwZ

The first is on ktoonsez kernel on stock rom. The second is Slimroms Kitkat. I have been using the first much longer than the second (which I moved over to just a few weeks ago).

Basically this soft reset tends to happen when I'm driving and using the GPS most often (and I notice that's also when the phone is usually the warmest). What happens is the phone just freezes up and sits there for a bit before finally doing a vibration and starting back up to the unlock screen. Kind of like I was restarting, but not quite. If it happened in the middle of calls, somehow it would keep the call going (at least on the stock kernel, I'm not sure about the new one yet). The other person just wouldn't hear what I was saying during the "soft reset"

On the stock kernel it used to happen even when not using the GPS. It was infrequent, but occurred I would say usually when I was using the phone more heavily... mostly just random though. Sometimes it would also not happen while using the GPS. That is to say it's a sporadic issue.

On this new Kitkat kernel it happened while I was navigating recently, but has not occurred when during any other operations (yet) that I can think of. Considering that was one of the first times I tried navigating with the kernel this worries me.

Does anyone know how I could approach this problem? Perhaps some logging I could do to get to the root issue? Some firmware I should perhaps try out?

Thanks.
29th August 2014, 01:16 AM   |  #2  
DocHoliday77's Avatar
Recognized Contributor
Flag HuntsVegas!!!
Thanks Meter: 6,400
 
9,140 posts
Join Date:Joined: May 2011
Donate to Me
More
Sounds hardware related to me. Especially if its happening on different roms.
Then again... I just looked at you image and you are still running 4.0.4 on one. But the other you are running 4.4.4. On one or tge other you most likely have a rather large gap between your firmware build and the rom. Id try flashing full stock firmware with Odin and test for a day or two. Up to you what build you want to use, but if it were me id update to 4.3. If you go to 4.3, keep in mind there is no going back.
Post Reply Subscribe to Thread

Tags
crash, firmware, gps, kernel, reset
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes