Post Reply

[kernel] Collection of kernels from different Custom-ROMs for S3mini - i8190

27th September 2014, 05:52 PM   |  #141  
Junior Member
Thanks Meter: 11
 
24 posts
Join Date:Joined: Sep 2014
Quote:
Originally Posted by Meticulus

Wow, great response! As you may or may not know I don't actually build for this device but I build for a similar one. I believe that this change:
https://github.com/Meticulus/android...case_gov.c#L69

... can disable the use case governor if any of the dev's what to try it.

EDIT: Or you can create an init.d script:

Code:
echo 0 > /sys/devices/system/cpu/usecase/enable

Funny you've come accross the same problem!

Setting "enable" to 0 works!! (and the CPU freqs are not reset anymore!)
Unfortunately I had to change it manually as it does not work from an init.d script (I mean, the script works, but Omni sets it to 1 during boot after my init.d script has previously set it to 0....)

Thanks so much, Meticulus! I'll try and convince the developers - @Fred6881 already appears inclined to trying it

---------- Post added at 06:52 PM ---------- Previous post was at 06:50 PM ----------

Quote:
Originally Posted by Fred6681

if we use this commit it should solve the problem, no ?

May I kindly ask you to try it?
Last edited by jri14; 27th September 2014 at 05:54 PM.
The Following User Says Thank You to jri14 For This Useful Post: [ View ]
27th September 2014, 06:15 PM   |  #142  
Meticulus's Avatar
Recognized Developer
Flag Springfield
Thanks Meter: 1,782
 
1,193 posts
Join Date:Joined: Dec 2011
Donate to Me
More
Quote:
Originally Posted by jri14

Funny you've come accross the same problem!

Setting "enable" to 0 works!! (and the CPU freqs are not reset anymore!)
Unfortunately I had to change it manually as it does not work from an init.d script (I mean, the script works, but Omni sets it to 1 during boot after my init.d script has previously set it to 0....)

Thanks so much, Meticulus! I'll try and convince the developers - @Fred6881 already appears inclined to trying it

---------- Post added at 06:52 PM ---------- Previous post was at 06:50 PM ----------



May I kindly ask you to try it?

In that case you could simply change the permission so that no one can change it after your init.d script has changed by doing:

Code:
echo 0 > /sys/devices/system/cpu/usecase/enable
chmod 444 /sys/devices/system/cpu/usecase/enable
That will change the permission to read only for all users after you have switched it off.
The Following 3 Users Say Thank You to Meticulus For This Useful Post: [ View ]
27th September 2014, 06:30 PM   |  #143  
golden-guy's Avatar
Senior Member
Flag Vienna
Thanks Meter: 672
 
278 posts
Join Date:Joined: Oct 2013
More
Have set uc_master_enable to false now in the kernel code, as I am just about to run a new build. So let's see.

Thanks to @Meticulus for your advice and also thanks @jri14 for your deep investigation on that issue.

EDIT: a "cat /sys/devices/system/cpu/usecase/enable" now returns 0, so just changing this boolean seems to have worked out
Last edited by golden-guy; 27th September 2014 at 07:40 PM. Reason: Update on the usecase governor setting
The Following 6 Users Say Thank You to golden-guy For This Useful Post: [ View ]
27th September 2014, 10:59 PM   |  #144  
Junior Member
Thanks Meter: 11
 
24 posts
Join Date:Joined: Sep 2014
Quote:
Originally Posted by golden-guy

Have set uc_master_enable to false now in the kernel code, as I am just about to run a new build. So let's see.

Thanks to @Meticulus for your advice and also thanks @jri14 for your deep investigation on that issue.

EDIT: a "cat /sys/devices/system/cpu/usecase/enable" now returns 0, so just changing this boolean seems to have worked out

Thanks, @golden-guy. Already tried it, and it does indeed work!
28th September 2014, 08:26 AM   |  #145  
grinder777's Avatar
OP Senior Member
Thanks Meter: 502
 
986 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by golden-guy

Have set uc_master_enable to false now in the kernel code, as I am just about to run a new build. So let's see.

Thanks to @Meticulus for your advice and also thanks @jri14 for your deep investigation on that issue.

EDIT: a "cat /sys/devices/system/cpu/usecase/enable" now returns 0, so just changing this boolean seems to have worked out

One question:

iif you set the uc_master_enable to false, can I still use Merticulus init.d script to enable usercsase again (by setting to 1 indeed)?

Thanks to all of you for this nice n new tweak!!!

Have fun!
28th September 2014, 09:41 AM   |  #146  
golden-guy's Avatar
Senior Member
Flag Vienna
Thanks Meter: 672
 
278 posts
Join Date:Joined: Oct 2013
More
Quote:
Originally Posted by grinder777

One question:

iif you set the uc_master_enable to false, can I still use Merticulus init.d script to enable usercsase again (by setting to 1 indeed)?

Thanks to all of you for this nice n new tweak!!!

Have fun!

No, by setting this flag to false it's completely disabled.
But this is not a typical cpufreq governor you can set in Performance settings.

Btw, the relevant line in the kernel config is
Code:
CONFIG_UX500_USECASE_GOVERNOR=y
So, I guess best approach would be just to set this to
Code:
CONFIG_UX500_USECASE_GOVERNOR is not set
and leave the usecase governor sources untouched.
The Following 3 Users Say Thank You to golden-guy For This Useful Post: [ View ]
28th September 2014, 10:35 AM   |  #147  
Recognized Contributor
Thanks Meter: 9,500
 
5,008 posts
Join Date:Joined: Mar 2013
More
Another solution would be to make the value depend on CONFIG_DVFS_LIMIT:

Code:
#ifndef CONFIG_DVFS_LIMIT
static bool uc_master_enable = false;
#else
static bool uc_master_enable = true;
#endif
Send from OnePlus One using Tapatalk
The Following 2 Users Say Thank You to Android-Andi For This Useful Post: [ View ]
29th September 2014, 05:51 AM   |  #148  
grinder777's Avatar
OP Senior Member
Thanks Meter: 502
 
986 posts
Join Date:Joined: May 2012
tenshi_xp gave us a kernel-ef to test:

"If some one wanna try kernel with extended frequencies(100MHZ, 600MHZ) no oc unstable atm."

There are random reboots but I guess it should be to stabilize with governor settings. Feel free to try and report.

Have fun!
Last edited by grinder777; 29th September 2014 at 01:15 PM.
29th September 2014, 01:14 PM   |  #149  
grinder777's Avatar
OP Senior Member
Thanks Meter: 502
 
986 posts
Join Date:Joined: May 2012
kernel-ef will not boot my PAC... <br />
Its just repeating start upon bootsplash - not entering bootamimation.<br />
Can I make a log somehow?<br/>
29th September 2014, 02:57 PM   |  #150  
grinder777's Avatar
OP Senior Member
Thanks Meter: 502
 
986 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by grinder777

tenshi_xp gave us a kernel-ef to test:

"If some one wanna try kernel with extended frequencies(100MHZ, 600MHZ) no oc unstable atm."

There are random reboots but I guess it should be to stabilize with governor settings. Feel free to try and report.

Have fun!

Update:

It is an Aroma installer based on Android-Andis Anykernel installer to keep the original ramdisk.
This contains also the latest 'normal' kernel of tenshi-xp, which is not provide here that time.

Changes of this latest kernel is just to set the BLN to a blinking interval of 1sec on and 5sec off...
I'm not really sure that time if I should also try to use this installer for kernel releases... feedback would be much appreciated...
Please try it out yourself

http://www.mediafire.com/download/ce...-KERNEL_ef.zip


Gesendet von meinem GT-I8190 mit Tapatalk 2

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S III Mini Android Development by ThreadRank