Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Broken Screen, Not Rooted, Lockscreened.

OP DUnderline

4th September 2014, 06:21 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: May 2013
More
SOLVED


(No success for me personally, but I'd still like to explain how I realised there's no hope left - description is at the bottom of this post)

Hi, not a regular poster in the S3 mini section, but a friend of mine has had his entire screen smashed. Somehow though, the phone is still breathing and can be turned on/off.

The problem is: My friend has asked me to extract his photos and similar media from the device's memory.

The device isn't rooted and I'm not sure if there's a default recovery mode or something like that built in the device.

I've tried connecting the device to my PC and it gets recognized and the drivers install themselves, but the device is empty. Moreover, I've downloaded KIES which also recognized the device, but says that there's a lockscreen and he can't go any further.

Any advices? Most of the other xda answers are for rooted phones so they haven't been very helpful, unfortunately.

There's a picture of the device in the attachments below, and KIES interface aswell.

<<EDIT>>

I'm using this http://forum.xda-developers.com/show....php?t=2339530 Recovery operation but it keeps saying "adb.exe" not found. I've installed ADB via the 15sec install ( http://forum.xda-developers.com/show....php?t=2588979 ) and entered the path correctly, but it still can't detect it. Any tips? perhaps i'm using the wrong ADB - I don't have c:\android\platform-tools folder - it's simply c:\adb\adb.exe.



SOLVED PROBLEM:
After messing with this for 2-3 days, I've decided to go with the simplest method - find a way to list all directories on the device and then see if there's anything in "sdcard" or a similar folder. To do this, after ADB recognizes your device, type : adb shell ls -R

adb shell ls -R will list a zillion directories so you may want to save the data into a .txt file. to do this, type adb shell ls -R > output.txt (or any other name).

After that, open the output.txt file and then use ctrl-f to find the sdcard folders and check if there's any data left in them.


IMPORTANT:
I've read that, without root permission, one cannot access the data or sdcard directories. The device I was working on had USB debugging OFF so there was no way I could root the phone in order to access the data directories.
Attached Thumbnails
Click image for larger version

Name:	s3mini.PNG
Views:	32
Size:	99.3 KB
ID:	2924493  
Attached Images
File Type: jpg 20140904_175811.jpg - [Click for QR Code] (212.0 KB, 25 views)
Last edited by DUnderline; 8th September 2014 at 12:54 AM. Reason: problem solved
6th September 2014, 08:10 AM   |  #2  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Sep 2009
Silly question, but did you use option 2 in RecoverData to change the path of ADB to c:\adb\?
6th September 2014, 01:51 PM   |  #3  
OP Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by aumedina

Silly question, but did you use option 2 in RecoverData to change the path of ADB to c:\adb\?

Yup, but it still can't find it. That's why I think the ADB-15sec install might be flawed.

There's a screencap of the Recovery + TotalCMD in the background in the attachments.


<EDIT>

Alright so I've followed an ADB tutorial (http://forum.xda-developers.com/show....php?t=2266638), installed all the SDK packages just to be sure.
ADB now recognizes the device after I've booted it into recovery mode. I've tried doing adb pull /data and it says 0 files pulled, 0 files skipped. Does this mean the device's internal memory is blank? No it doesn't, only the folder "data" is blank, other system data is present.



<EDIT 2> Can anyone please tell me the path to the internal camera storage folder? I may have fixed the problem if only I knew the correct path. SOLVED: The correct path is one of 4 combinations, usually these: /mnt/sdcard0/ /mnt/sdcard/ /storage/sdcard0/ /storage/sdcard/
Attached Thumbnails
Click image for larger version

Name:	adb.PNG
Views:	24
Size:	21.8 KB
ID:	2926703  
Last edited by DUnderline; 7th September 2014 at 11:51 PM. Reason: explained
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes