Lollipop Leak for Sprint Galaxy S5, TWRP for Micromax Canvas Magnus – XDA TV

Android 5.0 Lollipop has been leaked for the Sprint … more

Velocity is Like OpenTable on Steroids

We all enjoy a night out with friends or our significant other from time to time. However, there is … more

Android Lollipop Lands for the Sony Xperia Z Ultra

The undisputed king of the beasts–at least in Sony’s current stable,is the … more

Android 5.0 Lollipop in 3D–EVO 3D, That Is!

It is that time of the year once again. Flowers bloom (or snow falls, depending on which … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Vibration stopped working

OP cvkef

26th July 2014, 02:00 PM   |  #1  
OP Senior Member
Flag Athens
Thanks Meter: 41
 
127 posts
Join Date:Joined: May 2011
More
Hi everybody,

The vibration motor of my SGSIII Mini stopped working. It happened after I updated the Recovery to TWRP v2.7.1.1 by NovaFusion.

* CM 11 by NovaFusion [20140724]
* TWRP v2.7.1.1 by NovaFusion [20140720]

Flashing a stock ROM did not fix anything. Maybe pointless but also tried to flash another Recovery. Nothing changed.

Does anybody have an idea how to bring it back? Should I go for a vibration motor replacement?

Thank you!
26th July 2014, 03:44 PM   |  #2  
tys0n's Avatar
Recognized Contributor
Flag Stockholm
Thanks Meter: 1,258
 
1,982 posts
Join Date:Joined: Nov 2010
More
Does it still vibrate when you turn it on?
I mean that little vibrate before bootlogo appears.
26th July 2014, 04:47 PM   |  #3  
OP Senior Member
Flag Athens
Thanks Meter: 41
 
127 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by tys0n

Does it still vibrate when you turn it on?
I mean that little vibrate before bootlogo appears.

No. No vibration at all. Anywhere.
26th July 2014, 05:54 PM   |  #4  
tys0n's Avatar
Recognized Contributor
Flag Stockholm
Thanks Meter: 1,258
 
1,982 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by cvkef

No. No vibration at all. Anywhere.

That vibrate is there to tell that bootloader is loaded, before os loads, so if no vibrate is there then it's probably the motor or a loose connector to it.
Unless you got warranty left you could try to change it. They're probably cheep on eBay.
Otherwise take it to service.
The Following User Says Thank You to tys0n For This Useful Post: [ View ]
26th July 2014, 06:19 PM   |  #5  
OP Senior Member
Flag Athens
Thanks Meter: 41
 
127 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by tys0n

That vibrate is there to tell that bootloader is loaded, before os loads, so if no vibrate is there then it's probably the motor or a loose connector to it.
Unless you got warranty left you could try to change it. They're probably cheep on eBay.
Otherwise take it to service.

Thanks man. I'll take it for service probably.

Though, still wondering why it happened just after a recovery installation.
30th July 2014, 10:55 AM   |  #6  
Member
Thanks Meter: 8
 
63 posts
Join Date:Joined: Mar 2013
tap *#0*# in phone keyboard and click vibration (to test vibrator in stock rom, other rom i didnt try it)
6th September 2014, 07:08 PM   |  #7  
Junior Member
Thanks Meter: 2
 
21 posts
Join Date:Joined: Sep 2013
I have the same problem
Quote:
Originally Posted by cvkef

Hi everybody,

The vibration motor of my SGSIII Mini stopped working. It happened after I updated the Recovery to TWRP v2.7.1.1 by NovaFusion.

* CM 11 by NovaFusion [20140724]
* TWRP v2.7.1.1 by NovaFusion [20140720]

Flashing a stock ROM did not fix anything. Maybe pointless but also tried to flash another Recovery. Nothing changed.

Does anybody have an idea how to bring it back? Should I go for a vibration motor replacement?

Thank you!


So, does the vibration works on your phone right now?
7th September 2014, 01:05 PM   |  #8  
OP Senior Member
Flag Athens
Thanks Meter: 41
 
127 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by mastermind256

So, does the vibration works on your phone right now?

Nope. I have to find some time and give it for service. What happened with yours exactly? Do you have vibration when the phone powers on and boots?
7th September 2014, 06:00 PM   |  #9  
Junior Member
Thanks Meter: 2
 
21 posts
Join Date:Joined: Sep 2013
Quote:
Originally Posted by cvkef

Nope. I have to find some time and give it for service. What happened with yours exactly? Do you have vibration when the phone powers on and boots?

I don't know what happened to my device, it just stopped vibrating out of a sudden.. Maybe the device felt upset because it knew that I want to buy another phone..

Just out of a sudden no vibration during phone calls, messaging, power on / off.. My device is rooted by the way..

Sometimes, the vibration came slowly when I received notifications, but then disappeared again.. I don't know whats wrong.. maybe hardware related..
8th September 2014, 07:04 PM   |  #10  
OP Senior Member
Flag Athens
Thanks Meter: 41
 
127 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by mastermind256

I don't know what happened to my device, it just stopped vibrating out of a sudden.. Maybe the device felt upset because it knew that I want to buy another phone..

Just out of a sudden no vibration during phone calls, messaging, power on / off.. My device is rooted by the way..

Sometimes, the vibration came slowly when I received notifications, but then disappeared again.. I don't know whats wrong.. maybe hardware related..

the same as me. it's just died.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes