Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Please help! Random power off won't boot!

OP Trickster03

1st September 2014, 02:34 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
19 posts
Join Date:Joined: Jul 2012
Okay I will try to sum this up. My S3 was working fine and everything randomly I noticed issues with battery calibration It would be 100% then I would calibrate it and then unplug and then I'd instantly drop to 85%. Thought It was a battery issue and made a point to get a new one later. Then it kept working for another month or so then It started really screwing up the shutdown menu would randomly pop up and I'd back out of it.

Then randomly 3 seconds later the phone reboots. And it would keep doing that randomly I thought it might be a power button issue. Then as time goes on it got really bad to where it would simply reboot and not make it past the bootloader, It would not "reboot" more like a complete shutdown then I'd have to power it again and have it do the same thing. Seeing how I could not even make it past the bootloader I got a new battery, waited a week for it and then I put it in and the same issue happened. It would not get past the bootloader.

So I kept trying and trying and trying and it finally booted past that. And it stayed on for a whole night. I did everything on it I normally would and it was working great. Then the battery was getting low so I plug it in and was going to calibrate it after it was charged, I go back to it and it's dead again won't get past the bootloader once again. I'm completely out of ideas on how to fix this I pop'd off the button and blew in there and the button seems fine and everything still no change. I also can not get into recovery. It trys and loads but then shuts off. Anyway if anyone has any ideas on what this is or how to fix please help! I need my phone back! Thank you.

I'm running MOAR Lite version.


UPDATE: Took the phone apart and took a close look at the button it looks 100% fine...I saw a video on youtube that requires you to complete tear the button off and it works. But I don't know if the button is my main cause of this issue or if it will actually work. Some says it works, some says it does nothing...Please let me know thanks...

UPDATE 2: It will show that battery with spinning circle in it for like 1 second then turn off again. (When it is plugged in)
Last edited by Trickster03; 1st September 2014 at 04:33 AM.
2nd September 2014, 12:55 PM   |  #2  
Senior Member
Flag Washington
Thanks Meter: 217
 
1,313 posts
Join Date:Joined: Dec 2011
That's odd. But when it comes to the power button, dismantling and what not 90% of the time will show 0 issues. It will look perfectly fine when it's not. You playing with the power button I assume were pressing hard and normally to try testing it. It's a common issues on this version of the S3 to have faulty power button and you would need to get it repaired. Odly even slightly atmospheric changes can cause it to act different at different points. Some days it works fine, other days a very slight brushing over can cause it to screw up and trigger a manual shut down (holding for like 10 or 15 seconds).

Assuming that it is the power button, or to try, just do a variation of things to the power button itself. Use your finger nail to jiggle it around with different pressures. During boot if it shuts off, it could be the power button internally stuck, just jiggle it around.

This is all I can think of unless you bring it in to get repaired.
The Following User Says Thank You to ReapersDeath For This Useful Post: [ View ]
19th November 2014, 12:32 AM   |  #3  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Nov 2014
I was encountering the exact same problem. I would try to get into download mode and it would sit at the "Downloading" screen for about 5-7 seconds then the display would go blank. It won't make it into recovery either. Based on the above recommendation I took the whole phone apart and sprayed a lot of compressed air directly on the power button mechanism and the plastic case pressing the button in. I didn't see anything broken with the button when I did that.

It seems to be working now, I can boot into my Rom. Don't know how long this fix will last.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes