FORUMS

Top Forum Discussions

SlimKat settings.apk impossible to decompile?

1,205 posts
Thanks Meter: 318
 
By xdarkmario, Senior Member on 23rd August 2014, 11:19 PM
Post Reply Subscribe to Thread Email Thread
ok so im having issues decompiling settings apk in slimkat 4.4.4. For the fact of the matter i cant even install there framework-res.apk

i get
Code:
Exception in thread "main" brut.androlib.AndrolibException: Multiple resources: spec=0x01080220 drawable/default_wallpaper, config=-sw600dp-nodpi
        at brut.androlib.res.data.ResConfig.addResource(ResConfig.java:63)
        at brut.androlib.res.data.ResConfig.addResource(ResConfig.java:56)
        at brut.androlib.res.decoder.ARSCDecoder.readEntry(ARSCDecoder.java:199)
        at brut.androlib.res.decoder.ARSCDecoder.readConfig(ARSCDecoder.java:168)
        at brut.androlib.res.decoder.ARSCDecoder.readType(ARSCDecoder.java:134)
        at brut.androlib.res.decoder.ARSCDecoder.readPackage(ARSCDecoder.java:109)
        at brut.androlib.res.decoder.ARSCDecoder.readTable(ARSCDecoder.java:81)
        at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCDecoder.java:49)
        at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCDecoder.java:40)
        at brut.androlib.res.AndrolibResources.installFramework(AndrolibResources.java:687)
        at brut.androlib.Androlib.installFramework(Androlib.java:640)
        at brut.apktool.Main.cmdInstallFramework(Main.java:252)
        at brut.apktool.Main.main(Main.java:91)
when i try to install, resulting in the inability to decompile the settings.apk

any pointers?
 
 
24th August 2014, 01:24 AM |#2  
Notorious's Avatar
Senior Member
Flag Sydney
Thanks Meter: 5,146
 
Donate to Me
More
I think you need modified apktool because of The real dark slim feature
The Following User Says Thank You to Notorious For This Useful Post: [ View ]
24th August 2014, 01:38 AM |#3  
xdarkmario's Avatar
OP Senior Member
Thanks Meter: 318
 
More
Quote:
Originally Posted by Notorious

I think you need modified apktool because of The real dark slim feature

doesn't advanced apktool come with beta 9 apktool?
24th August 2014, 02:05 AM |#4  
Notorious's Avatar
Senior Member
Flag Sydney
Thanks Meter: 5,146
 
Donate to Me
More
Quote:
Originally Posted by xdarkmario

doesn't advanced apktool come with beta 9 apktool?

No idea
26th August 2014, 05:14 AM |#5  
CNexus's Avatar
Recognized Contributor
Flag ~/android
Thanks Meter: 13,896
 
Donate to Me
More
Yea slim releases their own apktool ever since they messed with the resources and broke normal apktool support on it
The Following User Says Thank You to CNexus For This Useful Post: [ View ]
26th August 2014, 06:19 AM |#7  
xdarkmario's Avatar
OP Senior Member
Thanks Meter: 318
 
More
Quote:
Originally Posted by Notorious

^found it @xdarkmario

https://github.com/SlimRoms/apktool/tree/kk-ver-2.x

is that for windows? looks a bit "linuxy"
The Following User Says Thank You to xdarkmario For This Useful Post: [ View ]
28th August 2014, 03:24 AM |#9  
xdarkmario's Avatar
OP Senior Member
Thanks Meter: 318
 
More
cant launch these files, says apktool.jar is corrupted and another error with aapt

found one from there website

http://slimroms.net/index.php/downlo...itkat-trds-3-0
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes