Post Reply

[Q] Phone won't connect to Odin

OP WoodenFox21101

1st July 2014, 04:55 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2014
I had to install the 4.3 firmware on my S3 since it got soft-bricked, but it seems that even though I installed the Samsung USB Drivers and installed Odin, my phone won't connect to Odin. I tried using different charging wires and different USB ports, and that doesn't work either. Even my friend's phone, which was an S3 as well, managed to connect to Odin with the same charging wires. Is it something to do with my phone? I need help with this.
1st July 2014, 06:32 PM   |  #2  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Sep 2011
My S3 updated to 4.3 (locked bootloader) and I can't make it connect via USB, it won't connect. I've tried everything, every link I can find, reghacks, drivers (countless installs/etc). I know what I'm doing, I've been using computers longer than a lot of posters here have been alive.

The thing is the device isn't telling the PC what type of Hardware it is, let alone the PC having drivers. I actually think my phone is toast - I'm glad it still charges and you can (if you're not rooted) root via Towelroot without a PC.

Good luck.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Verizon Galaxy S III Q&A, Help & Troubleshooting by ThreadRank