Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,777,893 Members 49,890 Now Online
XDA Developers Android and Mobile Development Forum

Samsung Allshare cast dongle firmware update problem solution

Tip us?
 
Alexoferith
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 1
Join Date: Jan 2014
Talking Samsung Allshare cast dongle firmware update problem solution

Hi, I just like to share my experience with problem connection my Galaxy S3 to my 2nd new Samsung Allshare cast dongle. As you can see, I have two Samsung Allshare cast dongles. One in the bedroom, the new one for the sitting room. The first one was bought long time ago and had been working fine. Got latest ME29 firmware. Connection is fast and no problem at all. Now, the price of this dongle has dropped so I proceeded to get myself another one for the sitting room, saving me unplugging it and plugging it, etc.. The new one has the JB version of firmware. The phone detected it without any problem but it kept on showing failed to connect message almost instantly when I tapped on the detected device on the touch screen. This is how I have ended up here at this website. After hours of reading, stock.rom, custome.rom, .pdk, etc.. I was still getting nowhere. But I don't know why. I kept on seeing in my head the blue LED showing on the dongle. Well, stupid of me, I had thrown away the packaging and with it the manual. So, I tried to download it from Samsung website. There is nothing about this dongle on the UK Samsung support website. From my experience with other worldwide hardware companies, so I tried Samsung support website in other countries. And I found a customer commented on another customer's query. So, here is the solution for those people with connection problem after updating the dongle's firmware to ME29. No harm to try this before going down the custom rom route.

After updating the firmware of the Allshare cast dongle, (by the way, my S3 has the latest jelly bean on), it will say Allshare is closed. At the same time, the red LED that was flashing would be solid red now (not flashing). Unplug the power (miniUSB) from the dongle, count to 10 and plug it back. The dongle should be showing a solid red LED now. Press and hold the button at the back of the dongle for about 15 seconds and the red LED should be flashing now. At this point, you can restart your phone just in case. Or just disable the WiFi and then enable it on your S3. Now, go to the dongle, press and hold the button for one or two seconds, the flashing red LED will change to solid BLUE. Now, go to your S3, turn on AllShare. It will detect the dongle. Tap on the detected device on your S3..... lo and behold....it connects!!!!!! Just to repeat, I have not downloaded or mod my S3 in anyway.

The blue LED is only for use in the very first time of connection. So, I guess updating the firmware constitutes a "first time connection" condition. I hope this information help. Good luck all.
The Following User Says Thank You to Alexoferith For This Useful Post: [ Click to Expand ]
 
packrat74
Old
(Last edited by packrat74; 24th February 2014 at 10:48 PM.) Reason: added word not
#2  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Feb 2014
Default What app is used to update dongle? Sorry if this is a NOOB question. ..

Hi,

I have not been able to find an app either on the Google play store or the Sammy app store to upgrade firmware.

The version shown is LJ02. But I seem to have constantly re - pair every time I try to use it.

Help on the firmware elsewhere on the forums someone mentioned there was a better device now (linksys dlink? I don't remember)

TIA - Thanks in advance

Frank
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes