Weird Touch screen problem, HELP please.

21 posts
Thanks Meter: 0
By NivPgir, Junior Member on 21st March 2014, 10:48 PM
Post Reply Subscribe to Thread Email Thread
Hi y'all,

I have this issue and I'm really clueless about how to solve it.

I flashed this ROM on my i9305:

it's one of the ROMs suggested in this forum. and it worked great.

I later on tried to flash an update to my twrp (it was version with flashify (BIG mistake never doing it again).
the image I tried to flash was (openrecovery-twrp-
I understand now it was not a good image for my phone.

at first the phone was bricked and I was only able to enter 'download mode'.
however, after I flashed the correct twrp, and reflashed the ROM, i got it working again, except the touch screen isn't working, all other buttons are working fine (back, home, power, volume up/down), but the touch doesn't respond not even in recovery mode(!!!).

my best result so far was when i flashed PhilzTouch and so I could navigate through recovery with the up/down volume, but still no touch.

can anyone help me here?
any clue?

I thought of maybe trying to use the 'NAND erase all' option via odin but I understood I need to get a pit file and a stock ROM first (I'm currently downloading the stock but have no idea of where to get the pit file)


21st March 2014, 11:02 PM |#2  
kamikaze702k's Avatar
Senior Member
Flag London
Thanks Meter: 271
Flash CWM recovery and install another ROM clean flash, should fix everything

Sent from my GT-I9195 CarbonKat 4.4.2
21st March 2014, 11:28 PM |#3  
spiderman07's Avatar
Senior Member
Thanks Meter: 68
or you can flash the original samsung rom from their website...
flash it with odin 3.07 as PDA and should work fine...after you flash it, might not boot...enter stock recovery...volume up + home + power and do factory reset and cache partition...after that you should work flawless..
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes