Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[FIX] Music Playback Crackling/Clicking Issue

OP knights.JayTana

8th July 2012, 05:42 AM   |  #1  
knights.JayTana's Avatar
OP Senior Member
Flag Davao City
Thanks Meter: 623
 
1,163 posts
Join Date:Joined: Jun 2011
More
First of all, id like to thank Gokhanmoral and Simone for the support... Special mention to TotallydubbedHD and Studiominal for the great contribution and to all who tested and helped...

The idea was first toasted by Gokhanmoral via PM, that it has something to do with idle status and not with hot-plug issue. Then Simone201 also posted about this on "official sound quality thread" which leads me to test dif configurations and combos... Then i came up with this little Fix:

1. You have to be rooted of course...
2. Flash Siyah Kernel (Sorry for this, since i only tested it with Siyah 1.3.3b and 1.3.7b)
3. Download & Install exTweak by Darek.Xan from the Playstore (Free one will do)
4. Grant Superuser
5. Navigate through the CPU Tab and set the CPU idle mode to; IDLE ONLY
6. Reboot

It was first tested with Siyah kernel 1.3.3b and was confirmed by Studiominal thru his "sinewave" that there were no crackling found in the graph. It has also been confirmed that it also work with 1.3.7b... I cant comment on other kernel since the test was thoroughly done with Siyah...

Hope this help... ENJOY!!!

For more info and progress about this finding, please read thru the thread
http://forum.xda-developers.com/show...633685&page=75
Last edited by knights.JayTana; 11th July 2012 at 09:25 AM.
The Following 13 Users Say Thank You to knights.JayTana For This Useful Post: [ View ]
8th July 2012, 08:28 AM   |  #2  
Senior Member
Flag Ann Arbor
Thanks Meter: 95
 
107 posts
Join Date:Joined: Aug 2010
More




Evidence provided
It seems like something in IDLE + LPA, AFTR + LPA, AFTR only causes the audio codec to suffer from power shortage that leads to turning the codec on and off really fast.
And.. to clarify, I only changed the cpu idle mode to IDLE ONLY, and disabled all the audio options that come pre-enabled both to see whether the idle mode is the culprit and wait for the new Voodoo Sound.
Last edited by studiominal; 8th July 2012 at 09:16 AM.
The Following 7 Users Say Thank You to studiominal For This Useful Post: [ View ]
8th July 2012, 08:36 AM   |  #3  
knights.JayTana's Avatar
OP Senior Member
Flag Davao City
Thanks Meter: 623
 
1,163 posts
Join Date:Joined: Jun 2011
More
Thanks for the graph Pal...
8th July 2012, 08:51 AM   |  #4  
henrybravo's Avatar
Senior Member
Flag Tulsa, OK
Thanks Meter: 618
 
1,641 posts
Join Date:Joined: Mar 2011
More
Thanks guys for sticking with this and finding the problem.
8th July 2012, 09:01 AM   |  #5  
Senior Member
Flag Ann Arbor
Thanks Meter: 95
 
107 posts
Join Date:Joined: Aug 2010
More
Now that the culprit has become more obvious(likely the DAC being not able to perform properly with that low current set by stock setting), we'll see more developers here digging down the kernel with power profiles
8th July 2012, 10:28 AM   |  #6  
FadeFx's Avatar
Senior Member
Flag Vienna
Thanks Meter: 1,980
 
6,742 posts
Join Date:Joined: Mar 2010
Donate to Me
More
Changed the setting to see what the impact on battery life is, i am not sure what lpe and aftr does, so not sure what effect we will see. Probably someone with more insight could clear this up...


tapatalked from Galaxy SIII
8th July 2012, 10:52 AM   |  #7  
knights.JayTana's Avatar
OP Senior Member
Flag Davao City
Thanks Meter: 623
 
1,163 posts
Join Date:Joined: Jun 2011
More
So far, its been good with mine... Good deepsleep... When playing music, stayed on 200Mhz according to CPUspy..
8th July 2012, 01:00 PM   |  #8  
Member
Thanks Meter: 19
 
82 posts
Join Date:Joined: Feb 2011
Quote:
Originally Posted by jaytana

Then i came up with this little Fix:

Russians found this fix in June)
http://translate.google.ru/translate...910007&act=url
8th July 2012, 01:04 PM   |  #9  
knights.JayTana's Avatar
OP Senior Member
Flag Davao City
Thanks Meter: 623
 
1,163 posts
Join Date:Joined: Jun 2011
More
Hope its been posted here earlier to save our time and effort testing every bit of it...
The Following User Says Thank You to knights.JayTana For This Useful Post: [ View ]
8th July 2012, 01:12 PM   |  #10  
Member
Thanks Meter: 19
 
82 posts
Join Date:Joined: Feb 2011
Quote:
Originally Posted by jaytana

Hope its been posted here earlier to save our time and effort testing every bit of it...

but this is not the solution, it is a crutch

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes