Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

How to fix - E:failed to mount /efs (Invalid argument)

529 posts
Thanks Meter: 397
Post Reply Subscribe to Thread Email Thread
5th January 2015, 07:29 AM |#21  
Thanks Meter: 3
Originally Posted by waldezca

At this step:

mount -w -t ext4 /dev/block/mmcblk0p3

at the end of the sentence put an space slash and efs, you have to see something like this:

mount -w -t ext4 /dev/block/mmcblk0p3 / efs --> (then push enter key, then make the last step "reboot" to reboot your phone).

Then your phone have to start normaly but in recovery mode [showing you a yellow information of the system phone]. Look at this thread


I have a T210 and I have done everything. I did the restore from 4.4.2 from SamMobile, I flashed it, then installed CMW, then follow the steps and it said it "can't find /dev/block/mmcblk0p3...". I've tried changing the -w and -t as somebody else suggested and nothing, then I tried your solution and it doesn't show any error (only "There are some filesystem-specific -o flags", is that it?) but it doesn't work either.... any ideas will be appreciated.

I'm still stuck on the Samsung logo.

Thank you so much.

PS Sorry for grammar and stuff, English is not my first language.
Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	346
Size:	127.9 KB
ID:	3099056  
13th January 2015, 10:55 PM |#22  
Junior Member
Thanks Meter: 0
Thumbs up Error: Device not Found
Originally Posted by awilmets

My S3-I9300 not detect in Adb. "error: device not found"

I think what may be happening is that you need to enable debugging mode. There is a really good guide for how to do it if you search for "enable usb debugging android s3" (sorry, can't link until I've made 10 posts).

Hope that helps! (Just about to start trying to recover my IMEI too)

EDIT: Ah... Two minutes after posting I tried to carry on with the guide, but also getting "error:device not found" when trying to access the adb shell after >mount/system. I guess this can't be done out of cwm recovery mode? Thanks!
Last edited by dansar324; 13th January 2015 at 10:59 PM.
20th January 2015, 02:47 AM |#23  
Junior Member
Thanks Meter: 0
Help with rooting
Hi, I've got this exact problem with my S3. I am having a problem with how to root the device if it's still stuck on samsung logo after the firmware flash (successful). All guides use some in-phone options. Will I be able to follow the root guide from this page: without booting up the phone? Could someone please give me some advice or a link to a guide that I can follow? I know how to use ADB in later stages, I just don't know how to root when the phone is DEAD.

Thanks in advance

(initial problem: phone stuck on samsung logo, GT-I9300)
13th March 2015, 08:57 PM |#24  
Junior Member
Thanks Meter: 0
help me
I did this tutorial and works fine, but now i dont have de same IMEI, how can i put the original IMEI?
20th March 2015, 01:39 AM |#25  
Thanks Meter: 4
Originally Posted by anukilimanoor

My phone was dead due to unknown reason. It was very slow for last couple of days, so I reboot the phone into recovery and then wipe cache and dalvik. After the wipe I reboot the phone but it stuck on Samsung logo. So I tried different unsuccessful methods like, flash stock ROM, restore efs folder, etc...

After flashing the stock ROM, rebooted the phone into recovery for factory reset, then only I noticed the error E:failed to mount /efs (Invalid argument). If you are on CWM recovery then you may not see this error.

Flash an official firmware from sammobile
Flash CWM recovery
Boot into Recovery
Select mount and storage -> mont /system
Connect your phone to PC using USB cable
Open ADB command window and type the following commands

adb shell
mke2fs /dev/block/mmcblk0p3
mount -w -t ext4 /dev/block/mmcblk0p3
Now your phone will boot, but it may be in factory mode (ie you can see yellow box showing some ROM information).

Remove factory mode:
There are different methods that we can use to remove factory mode
In my case
1. Installed custom ROM to get root access
2. Instaled kTool
3. Copy the backup of my efs into sdcard (you can use .img or tar file)
4. Open kTool and restore the efs
5. Reboot the phone

* This method is the easiest and safest method because when you are getting the efs mount error there is a chance of loosing your IMEI and some other files, in that situation the following methods will not work.


1. Root your phone (Either root manually or install a custom ROM)
2. Install ES File Explorer
3. Open ES File Explorer and turn on Root Explorer
4. Navigate to /efs folder
5. Open factorymode as txt in ES Note Editor
6. Change it from OFF to ON and save
7. Reboot your phone


1. Root your phone (Either root manually or install a custom ROM)
2. Install Terminal Emulator
3. Run the following commands
rm /efs/FactoryApp/keystr
rm /efs/FactoryApp/factorymode
echo -n ON >> /efs/FactoryApp/keystr
echo -n ON >> /efs/FactoryApp/factorymode
chown 1000.1000 /efs/FactoryApp/keystr
chown 1000.1000 /efs/FactoryApp/factorymode
chmod 0744 /efs/FactoryApp/keystr
chmod 0744 /efs/FactoryApp/factorymode

I have the same problem here,But I didn't Flashed anything on my phone since the day I Bought it
I think it has something to do with my Faulty battery (When it hits 2% My s3 gets Voltage Spikes)
btw I checked Everything and beside this efs Error ,Everything is Fine (NAND Memory,eMMC etc.)
After reading OP , I Flashed CWM Recovery and tried to do what You said Just to find out another problem,I Can't get my Windows to Recognize My s3 While it's in Recovery Mode,so my device won't show up using "adb devices" Command(GT-I9300 Shows up in Device Manager but w/o any drivers)
I'm a Complete Newbie on these stuff so Please Help me
30th March 2015, 01:57 PM |#26  
Junior Member
Thanks Meter: 2
I have to same problem, and also the command

"mount -w -t ext4 /dev/block/mmcblk0p3"

isn't working, in any way described here. But I was still able to boot the phone whithout it.

Nonetheless I'm still with the corrupted /efs, and tried to flash the samsung stock again.
Now again I'm stuck at the Samsung boot screen.
11th May 2015, 05:07 AM |#27  
Junior Member
Thanks Meter: 0
same problem with S4 gti-i9500
i've got the same problem with my galaxy s4 gt-i9500, is it the same method ?
2nd June 2015, 04:40 PM |#28  
Senior Member
Thanks Meter: 25
Has anyone got a solution to this yet or are we bricked?

I have an S4 (I9505) - it mounts in ADB but none of the commands above dont work for me
9th June 2015, 09:52 AM |#29  
Junior Member
Thanks Meter: 0
Efs error
Hello. I have a similar problem on my s4 i9505. I get: E: Unable to mount '/efs/. So I followed the instructions. On adb, I get: Not enough space to build proposed filesystem while setting up superblock. And then, the efs error remains.

Please help.
9th June 2015, 10:20 AM |#30  
Senior Member
Thanks Meter: 25
So basically I have this issue and the knock-on effects are as follows:

1) if i flash the official Lolipop rom along with the official PIT file for my device, the device boots into lolipop no problem and all LOOKS fine....uuuntil i start getting random messages about factory mode. it then drops my wifi and wont let me put it back on for a while. also, when i reboot, it forgets the wifi passwords and i have to keep putting it in. When i try to use terminal emulator to remove factory mode it doesnt work as there is nothing in my efs folder...what the hell can i do to obtain these files which are supposed to be in my efs folder? I think this is the root of my problems.

2) If i try and flash any cyanogenmod rom (lolipop or otherwise) it just bootloops all the way
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes