FORUMS

Top Forum Discussions

How to fix - E:failed to mount /efs (Invalid argument)

529 posts
Thanks Meter: 398
 
Post Reply Subscribe to Thread Email Thread
4th August 2015, 01:29 AM |#41  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by nk33

I mentioned many previous times that I have exactly this issue and flashing cm11 sortedd this out for me. 100%.

Sent from my SM-G925F using XDA Free mobile app

That didn't helped me - maybe I'm doing something wrong?
I flashed Philz CWM recovery, wiped data,cache,dalvik, then I flashed newest CM11 (12.07.2015) and still "Emergency calls only".
Still in Settings->About phone->Status Imei is 0049... (but Serial number changed from 000... to a random number)
Any suggestions?

And If I understand correctly efs and imei problems occur mostly during rom change - but my problems started during normal use of my S3 (I was downloading GTA China Town from Google Play store when my phone stucks and didn't reboot correctly, then info about corrupted efs etc...)

Maybe my problems are somehow related to error which I had with ADB?:
Quote:
Originally Posted by lukecz81

So I flashed CWM recovery, connect with ADB and used commands:
adb shell
mke2fs /dev/block/mmcblk0p3
mount -w -t ext4 /dev/block/mmcblk0p3 (at this command I had error: can't find /dev/block/mmcblk0p3 in /etc/fstab)
reboot

Last edited by lukecz81; 4th August 2015 at 07:17 AM.
 
 
4th August 2015, 02:03 PM |#42  
Senior Member
Thanks Meter: 28
 
More
Quote:
Originally Posted by lukecz81

That didn't helped me - maybe I'm doing something wrong?
I flashed Philz CWM recovery, wiped data,cache,dalvik, then I flashed newest CM11 (12.07.2015) and still "Emergency calls only".
Still in Settings->About phone->Status Imei is 0049... (but Serial number changed from 000... to a random number)
Any suggestions?

And If I understand correctly efs and imei problems occur mostly during rom change - but my problems started during normal use of my S3 (I was downloading GTA China Town from Google Play store when my phone stucks and didn't reboot correctly, then info about corrupted efs etc...)

Maybe my problems are somehow related to error which I had with ADB?:

Aha! I flashed the first cm 11 .that was the only one that worked for me

Sent from my SM-G925F using XDA Free mobile app
4th August 2015, 02:09 PM |#43  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by nk33

Aha! I flashed the first cm 11 .that was the only one that worked for me

Sent from my SM-G925F using XDA Free mobile app

I don't think it will make any difference but when I get back from work I wil try to flash the very first CM11 (maybe you can provide exactly date of CM11 that you've used?)
I'm losing hope to succesfully repair my S3 & IMEI

EDIT
The oldest versions of CM11 can't be downloaded due to an 404 error -they're deleted from CM site
Last edited by lukecz81; 5th August 2015 at 10:18 PM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes