FORUMS

[Q] Not able to pick up a 4G LTE signal on my i9305...

38 posts
Thanks Meter: 9
 
By rasseru16, Member on 17th February 2014, 07:28 PM
Post Reply Subscribe to Thread Email Thread
Hi, I have a Samsung Galaxy S3 I9305 LTE which is originally from Three UK, but I have tried a couple of stock roms, one of which was unbranded from Germany and another one which is the EE UK one, all of these on Android 4.3.

Now my phone is able to pick up a 2G or 3G signal (be it 3G/H/H+ whatever) but it will not pick up a 4G LTE signal even though the same EE4G sim card I have will work perfectly fine with signal in my Samsung Galaxy Tab 3 LTE?

What am i doing wrong or is there any way to enable the phone to actually use 4G? (I have made sure the network mode is set to include 4G as "Auto Mode")

~ Many thanks for anyone who is able to offer me the time to help ~
 
 
18th February 2014, 10:37 PM |#2  
Member
Flag Bottrop
Thanks Meter: 6
 
More
Maybe try another modem. I am from Germany and had to change modem from xxuemkc modem to xxbme1 modem, because lte didn't work on first modem, either.

Try one of these

http://forum.xda-developers.com/show....php?t=2010116

Good luck.
The Following User Says Thank You to Bautinho88 For This Useful Post: [ View ]
20th February 2014, 06:21 PM |#3  
OP Member
Thanks Meter: 9
 
More
Thumbs up
Quote:
Originally Posted by Bautinho88

Maybe try another modem. I am from Germany and had to change modem from xxuemkc modem to xxbme1 modem, because lte didn't work on first modem, either.

Try one of these

http://forum.xda-developers.com/show....php?t=2010116

Good luck.

Hi, I have managed to solve my own question but thank you ever so much for taking the time to help me

It turns out that I had to downgrade my phone to 4.1.2 through Mobile Odin and then enter Service Mode and from the Debug Menu there is an somewhere within the UMTS, DRX Control option to enable LTE DRX 0X1 1X0 or something on those lines, so I enabled it and voila i now get 4G!

Last edited by rasseru16; 21st February 2014 at 08:04 PM. Reason: Spelling error
The Following 3 Users Say Thank You to rasseru16 For This Useful Post: [ View ]
19th May 2015, 03:19 PM |#4  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by rasseru16

Hi, I have managed to solve my own question but thank you ever so much for taking the time to help me

It turns out that I had to downgrade my phone to 4.1.2 through Mobile Odin and then enter Service Mode and from the Debug Menu there is an somewhere within the UMTS, DRX Control option to enable LTE DRX 0X1 1X0 or something on those lines, so I enabled it and voila i now get 4G!

Same issue can you help me
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes