5,597,707 Members 34,084 Now Online
XDA Developers Android and Mobile Development Forum

Battery life is terrible!

Tip us?
 
Luzmo
Old
#1  
Senior Member - OP
Thanks Meter 32
Posts: 218
Join Date: Dec 2011
Default Battery life is terrible!

Hey guys! Sorry to bother you (Again) but I have some serious issues with my battery. First; My phone won't go to deep sleep, Second; When using phone, I think my cpu is locked in 200mhz.

I have same problem pretty much with every rom. And I know that people will say check wakelocks etc. but I don't understand that stuffand I'd like to learn.

Because of those problems my battery won't last more than 8 hours! Which is really bad

Please help! Thanks!

Sent from my GT-I9305 using Tapatalk
 
JellyYogurt
Old
#2  
JellyYogurt's Avatar
Senior Member
Thanks Meter 168
Posts: 917
Join Date: Dec 2013
Quote:
Originally Posted by OhBuggerit2k2 View Post
Am I missing something here?

When I install the various .cab files that mamaich and others have posted to the wiki they install to the standard 60.30mb "storage" memory and not to the 123.15mb "program" memory.

Is this correct? or is there a way to install them to the Program Memory?
U just answered urself. Download wakelock checkers in playstore. Or just flash a rom and dun download anything. Then install a few per day and narrow down the app.

Sent from my GT-I9300.
Give a thank if i helped you.
 
Juuliet
Old
#3  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
i have the same problem since i've updated to android 4.3 (officially, no root).
Since the update, my phone doesn't go into deep sleep at all because of the wakelock mdm_hsic_pm0
Does anyone know what that could be? No wifi/wlan, no gps, LTE is working 95 % of the time in my area and theres no other wakelock like fast_dormancy that keeps my phone awake.
I've tried to close almost every app in the manager, from google play services to the dropbox app, everything.
The wakelock still shows and keeps my phone alive all the time: goes from 100 % to 25 % at night - 9 h without touching the phone.

In 2 Weeks it happened to me two times that the wakelock dissappeared without me knowing what i possibly did to remove it.
It also happened two or three times that the battery didnt charge until i tried another charger - then the old one worked again too.
 
Rem-X
Old
#4  
Senior Member
Thanks Meter 1
Posts: 125
Join Date: Oct 2010
Location: Budapest
Got the same problem right now... This mdm_hsic_pm0 does not my phone to go to deep sleep...

Küldve az én GT-I9305-ről Tapatalk használatával
 
jetbruceli
Old
#5  
jetbruceli's Avatar
Senior Member
Thanks Meter 405
Posts: 2,310
Join Date: May 2011
Location: Bamberg, Germany

 
DONATE TO ME
Check battery in settings and see if shows media server
Then try a day with out ext SD.
I think it has something to do with ext sd

sent from my iPhone 6s 64gb 5.7inch Super Oled screen and spen
 
Tlailaxu
Old
#6  
Member
Thanks Meter 10
Posts: 74
Join Date: Nov 2013
Quote:
Originally Posted by jetbruceli View Post
Check battery in settings and see if shows media server
in my case,it is indeed the media server that drains a lot.is there no was to disable that service/the drain without pulling out the additional sdcard?
it shouldn`t act like a media server,it is only there for storage
 
el.mariachi
Old
(Last edited by el.mariachi; 22nd January 2014 at 01:15 PM.)
#7  
Junior Member
Thanks Meter 6
Posts: 17
Join Date: Dec 2010
Did anyone find a solution?
I am also suffering from mdm_hsic_pm0 wakelocks keeping my phone awake 95% of the time. (Which results in about 8% battery drain per hour.)

Media server does not show up.
 
hayabusa08
Old
#8  
hayabusa08's Avatar
Senior Member
Thanks Meter 70
Posts: 484
Join Date: Jan 2011
Location: Singapore

 
DONATE TO ME
Read somewhere formatting yur extsd might help. Might be wrong though. No harm trying. Backup all contents before formatting extsd.

Sent from my GT-I9305 using Tapatalk

---------- Post added at 11:29 PM ---------- Previous post was at 11:28 PM ----------

http://forum.xda-developers.com/showthread.php?t=753294

Try look at this. Might help

Sent from my GT-I9305 using Tapatalk
 
jetbruceli
Old
#9  
jetbruceli's Avatar
Senior Member
Thanks Meter 405
Posts: 2,310
Join Date: May 2011
Location: Bamberg, Germany

 
DONATE TO ME
nothing is working for me. i might have to factory reset but I dont want to! arrgg
 
JellyYogurt
Old
#10  
JellyYogurt's Avatar
Senior Member
Thanks Meter 168
Posts: 917
Join Date: Dec 2013
Download rescan media root from play store. It disables media server. U nid root btw.

Sent from my GT-I9300 using xda app-developers app

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Polish Your Custom Themes with Theme Debugger

Creating a custom Android theme from scratch can be quite the laborious task. In addition to … more

Clean Up Your Logcat Code with Lib Cleaner

Some of you may think that writing code is the hardest part of development. It’s not, as the … more

Tweak Your Xperia Device’s Camera App Yourself

We’ve come to expect nearly perfect cameraperformancein our modern day … more