Default [HELP] No Service (emergency calls only), but mobile data works, IMEI intact

Hey guys,

I got some issue with my friend's S3 i9305. That phone is not able to place/receive any call/message but it's mobile (GSM) data is working.

Initially when I got this phone from him it auto updated itself to 4.3 (from 4.1.x I guess?). At this stage (both, before & after 4.3 auto update) there was no sim inside it & neither he nor I tested if calling was working.

After that he asked me to update it to KitKat. So, before doing anything else I backed up the IMEI/NV using this tutorial & then proceeded with rooting, installing TWRP (using Skipsoft Samsung Unified Kit) & then OmniROM 4.4.4 (nightly) with PA micro Gapps package along with the XXUEMKC radio.

At this stage, when I inserted the sim I noticed that it is showing "No Service" "Selected network (<Network Name>) not available". Tried to call & it returned "Not registered on network". Tested it with another (network) sim, same issue. Both sim works fine on other mobile phones. Tried CyanogenMod 11, but nothing changed. Flashed couple different Radios & changed to Agni kernel, but no luck.

Currently I'm back to stock 4.3 rom (from sammobile). Even tried after restoring that IMEI/NV data using QPST tool. But still stuck with no service.

IMEI is intact, but one thing that I noticed with serial number is that the stock rom displays the correct serial number (RFxxxxxxxxx) in about section, while the app "Phone Info Samsung" displays two different serial numbers, 1) Serial Number: some random string 42f7xxxxxxxxx & 2) Samsung Serial Number: RFxxxxxxxx <- correct one. Also that CyanogenMod rom too displays that random string as serial number in the phone about section.

Here's the output of *#1234#
AP: I9305XXUEMKC
CP: I9305XXUEMK1
CSC: I9305XEFEMK1

Phone seems to be from France & I'm using it in India. Since it's unbranded phone, so I don't think it is/was network locked and mobile data is working fine.