[Solved] [I9305] crash reboot, dalvik cache and battery problem

16 posts
Thanks Meter: 2
By Dark Smile, Junior Member on 2nd July 2014, 11:08 AM
Post Reply Subscribe to Thread Email Thread
Hey Guys,

First the relevant data

Galaxy S3 LTE I9305
ROM: Carbon Rom KK 4.4 (
Kernel: Standard Carbon Kernel

Problem Description:
The phone reboots itself sporadic and then gets stuck at bootlogo. It is completly sporadic so sometimes it is when i am using it heavyly sometimes just when i end a call or want to do something else not intensive.
The only solution then is to go to recovery, wipe cache and dalvik cache and the reboot. The phone the rebuilds the dalvik cache and crashes a few times while the process.
But there are some more strange things going on:
- Battery
The battery is almost fully charged, when the phone crashes and reboots a few times while rebuilding dalvik cache the battery show up empty suddenly! Phones turns off and only turns on when plugged to charger and then shows battery level 0% when running again. The charging process begins normally from there.
Sometimes the battery shows empty as described above but when i restart the phone again and rebuild dalvik cache it's on its old state (almost full).
- Kamera
When i take pictures, sometimes the camera shows some red stripes all over the stored picture or even in focus mode. Then the screen starts flickering and phone crashes as describes above.
When crashed and running again after some tries to build dalvik cache, sometimes i enter PIN to unlock sim card and nothing happens. Then the screen starts flickering again and it crashes. Procedure start again then.
- Charger
When the phone crashes and i plug it to the charger before rebuilding dalvik cache, it runs through without any errors like it should.

What i tried so far:
- Other ROM (AOKP, CM, other Carbon Rom builds)
- wiped everything (really everything on internal storage) and clean install
- reflash after crash (dirty)
- reflash after crash (wipe)
- leave phone with just a few apps after clean install (thought it could be one of my apps)
- recording a logcat (aLocRec and logcat reader) but the problem here is as the logcat is stored in memory it's not accessible after crash (reboot).

What i want to try next:
- try getting a logcat via adb and hope it crashes while logging
- other kernel (don't want to try this, would be last option).

Does anyone have an idea?

Dark Smile
Last edited by Dark Smile; 5th July 2014 at 09:56 AM.
2nd July 2014, 02:32 PM |#2  
Thanks Meter: 13
One idea may be a bad battery which may cause inconsistent power supply and all kind of strange errors. Especially because, as you write, with charger = stable voltage source things look good.

2nd July 2014, 02:36 PM |#3  
Dark Smile's Avatar
OP Junior Member
Thanks Meter: 2
Thanks for the tip s3axel, i'll buy a new one when i get off work and try it.
2nd July 2014, 04:33 PM |#4  
Dark Smile's Avatar
OP Junior Member
Thanks Meter: 2
I just ordered a original battery from here:

I'll give feedback when arrived and tested.
3rd July 2014, 12:29 PM |#5  
Thanks Meter: 13
Good luck
The Following User Says Thank You to s3axel For This Useful Post: [ View ]
5th July 2014, 09:54 AM |#6  
Dark Smile's Avatar
OP Junior Member
Thanks Meter: 2
Unbelievable, it was the battery! No problems with the new battery. Thanks for your advice s3axel

Sent from my GT-I9305 using XDA Free mobile app
11th December 2014, 07:44 AM |#7  
Junior Member
Flag Portland, OR
Thanks Meter: 0
Thumbs up
I was experiencing exactly EVERY one of those issues besides the battery jumping to zero. It would even crash when opening messaging, chrome, contacts, literally everything crashed it.
I tried everything that you tried, and was about to logcat from my computer too lol.
And without looking it up I had the idea, maybe its the battery and it just cant support the changes in power needs, maybe I should buy a new battery!

Thought, nahh... ill try some more things first. Then boom! Reading this post I felt like I wrote it!

This thread just blew my mind!!!
Post Reply Subscribe to Thread

battery, crash, dalvik cache, i9305, reboot

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes