Post Reply

[Q] I9305 Stock 4.3 How to open Service Mode

OP AdamOslo

16th February 2014, 03:48 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2014
Hi.
I am using my GT-I9305 for testing of mobile base stations (need to be able to lock mobile to the 1800 MHz LTE). When i was using stock android ver 4.1.2 - it was possible to open service mode from dialer (*#197328640#)
After adnroid update to ver 4.3 it is not longer possible.

I am trying to find solution to have back Service Mode on my mobile.
Maybe somebody can help me to find solution.

1. I rooted my phone and in /system/apps there is app called serviceModeApp.apk
i cannot find here ServiceModeApp_RIL.apk
there is also no HiddenMenu.apk here

2. In /efs/carrier there is file called HiddenMenu and when i edit this file it contains word OFF

I have changed OFF to ON in /efs/carrier in file HiddenMenu
I copied into /system/apps ServiceModeApp_RIL.apk, HiddenMenu.apk and i overwrited serviceModeApp.apk (i get version from android 4.1.2)

And nothing works for me.
I will apreciate any help.

I was wondering - if it is possible to add Service Mode into custom rom, maybe it will be possible to ADD it to the stock rom (copying some files, changing some files...) XDA is place with most experienced android experts - maybe somebody will find a minute to help me ? Please!
2nd March 2014, 03:59 PM   |  #2  
Member
Thanks Meter: 7
 
32 posts
Join Date:Joined: Nov 2010
I am having the same issue here... not able to use service mode on the new 4.3 firmware either Anyone able to offer some help preety please?

Thank you kindly
3rd March 2014, 01:11 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2014
Angry
Maybe somebody is interested to fix this problem and get paid for it?
I think - Maybe I can come with some paypal donation if somebody will manage to fix this problem.
somebody interested?
4th March 2014, 03:28 PM   |  #4  
shucrut's Avatar
Senior Member
Thanks Meter: 129
 
455 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by AdamOslo

Hi.
I am using my GT-I9305 for testing of mobile base stations (need to be able to lock mobile to the 1800 MHz LTE). When i was using stock android ver 4.1.2 - it was possible to open service mode from dialer (*#197328640#)
After adnroid update to ver 4.3 it is not longer possible.

I am trying to find solution to have back Service Mode on my mobile.
Maybe somebody can help me to find solution.

1. I rooted my phone and in /system/apps there is app called serviceModeApp.apk
i cannot find here ServiceModeApp_RIL.apk
there is also no HiddenMenu.apk here

2. In /efs/carrier there is file called HiddenMenu and when i edit this file it contains word OFF

I have changed OFF to ON in /efs/carrier in file HiddenMenu
I copied into /system/apps ServiceModeApp_RIL.apk, HiddenMenu.apk and i overwrited serviceModeApp.apk (i get version from android 4.1.2)

And nothing works for me.
I will apreciate any help.

I was wondering - if it is possible to add Service Mode into custom rom, maybe it will be possible to ADD it to the stock rom (copying some files, changing some files...) XDA is place with most experienced android experts - maybe somebody will find a minute to help me ? Please!

You can try Apex launcher. After installing, go to it and long press somewhere in home screen, then select shortcuts > Activities

Then you can play a bit here, scroll down to service mode and test if any activity in this menu actually opens the service mode. If you succeed let us know
5th March 2014, 10:05 AM   |  #5  
Member
Thanks Meter: 7
 
32 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by shucrut

You can try Apex launcher. After installing, go to it and long press somewhere in home screen, then select shortcuts > Activities

Then you can play a bit here, scroll down to service mode and test if any activity in this menu actually opens the service mode. If you succeed let us know

Hi, I have tried that and it just says 'Application not installed' I have tried to re-install it from the /system/app folder but it still shows the same error.

14th March 2014, 07:05 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2014
Apex launcher is not helping. Any other ideas?
I am wondering - is it possible that it is sooo... complicated?! I searched whole internet and NOBODY managed to have Service mode on Stock Android 4.3. that is sad
21st March 2014, 09:05 PM   |  #7  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Dec 2013
Quote:
Originally Posted by AdamOslo

Apex launcher is not helping. Any other ideas?
I am wondering - is it possible that it is sooo... complicated?! I searched whole internet and NOBODY managed to have Service mode on Stock Android 4.3. that is sad

Have you a stable broadband and imei ?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes