Post Reply Subscribe to Thread Email Thread

[Q] Poor signal/battery drain on SIII LTE EE/Orange

25th July 2014, 12:13 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jul 2014
Hi,

For the past 6 months I have been getting really bad signal and battery drain on my Samsung SIII LTE.

Here is what I have loaded on it:
Android version 4.3
BaseBand version I9305XXUEMK1
Kernal Version:
3.0.31-2051278
dpi@DEL156#1
Thu Dec 12

Full root has been done on this phone for titanium backup.

I really am fed up of this phone, it crashes all the time. It has a fit whenever I need to make a phone call, calls also drop out.

By the way it is on the UK's so called fastest network EE/Orange.

Please can someone point me into the right direction to get this problem fixed?

All help is much appreciated

Thank you in advance.
25th July 2014, 01:09 AM   |  #2  
daedric's Avatar
Senior Member
Flag Porto
Thanks Meter: 374
 
1,841 posts
Join Date:Joined: Dec 2006
More
Are you using a case?
25th July 2014, 03:45 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by daedric

Are you using a case?

If you mean another battery then yes I have tried that option and my phone does have a case.
25th July 2014, 07:43 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jul 2014
Anyone?

I have searched across this forum and cannot find out a basic way of either installing a custom rom or finding the EE stock rom.
25th July 2014, 10:19 PM   |  #5  
Raistlin1158's Avatar
Senior Member
Thanks Meter: 122
 
533 posts
Join Date:Joined: Dec 2010
How did you root it ?
26th July 2014, 12:42 AM   |  #6  
daedric's Avatar
Senior Member
Flag Porto
Thanks Meter: 374
 
1,841 posts
Join Date:Joined: Dec 2006
More
I meanta case, a protecting case. A cover.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes