Early Lollipop Ports for Micromax A116 and A117

It feels like it was only yesterday when Google announced the mysterious Android L.After … more

Now Gesture Tweaks Replaces Google Now with Custom Action

On most modern Android devices with software navigation keys, swiping up from the … more

ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Signal drops probably internal damage

OP slizza786

9th June 2014, 01:46 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jul 2012
Hi all.

I've dropped my phone quite a few times and it's affected my signal.

The reception on the phone is very weak and drops in certain places where it use to have good signal before. Also sometimes people tell me I sound like a robot over the phone so it's got to be an internal damage.

Iv already changed the speaker/microphone part of the phone but the problem continues, my next geuss is the wifi signal antenna cable.

Any ideas of what may be the may cause?

Sent from my GT-I9305 using Tapatalk
11th June 2014, 08:04 AM   |  #2  
hahmad78's Avatar
Member
Flag faisalabad
Thanks Meter: 18
 
72 posts
Join Date:Joined: Jan 2013
More
Wink
Quote:
Originally Posted by slizza786

Hi all.

I've dropped my phone quite a few times and it's affected my signal.

The reception on the phone is very weak and drops in certain places where it use to have good signal before. Also sometimes people tell me I sound like a robot over the phone so it's got to be an internal damage.

Iv already changed the speaker/microphone part of the phone but the problem continues, my next geuss is the wifi signal antenna cable.

Any ideas of what may be the may cause?

Sent from my GT-I9305 using Tapatalk

have you tried some different rom and modem.? if not than try something different. i also faced such issue but after changing rom and specially modem, now me trouble free
11th June 2014, 10:15 AM   |  #3  
spiderman07's Avatar
Senior Member
Thanks Meter: 43
 
202 posts
Join Date:Joined: Dec 2012
More
assuming he didn't flashed any roms between drops....i think it's antenna related...that antenna is small and looks quite fragile...it's a hardware problem...i suggest going to your local repair shop...
31st July 2014, 07:13 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by spiderman07

assuming he didn't flashed any roms between drops....i think it's antenna related...that antenna is small and looks quite fragile...it's a hardware problem...i suggest going to your local repair shop...

I think it's definitely an internal issue. Signal drops all the way at certain locations when it never use to and some people say I have a robots voice so I have to call them back. Does anyone have any pictures of where the antenna is located in the phone?

Sent from my GT-I9305 using Tapatalk
31st July 2014, 04:42 PM   |  #5  
Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Feb 2011
Having the same problem here. Dunno exactly when it started but I'm getting lower signal everywhere than I used to get, indoors am having trouble getting any signal at all when it used to be fine.

Tried multiple different ROMs/Radios and a new Sim Card and it's not solved the problem

Also thinking I've just dropped it too many times.
Last edited by aerozeppel; 31st July 2014 at 04:47 PM.
31st July 2014, 05:21 PM   |  #6  
spiderman07's Avatar
Senior Member
Thanks Meter: 43
 
202 posts
Join Date:Joined: Dec 2012
More
Quote:
Originally Posted by aerozeppel

Having the same problem here. Dunno exactly when it started but I'm getting lower signal everywhere than I used to get, indoors am having trouble getting any signal at all when it used to be fine.

Tried multiple different ROMs/Radios and a new Sim Card and it's not solved the problem

Also thinking I've just dropped it too many times.

it means is a hardware problem...
3rd August 2014, 06:53 AM   |  #7  
opssemnik's Avatar
Senior Member
Flag Porto Alegre,Rio Grande Do Sul,Brasil
Thanks Meter: 778
 
1,204 posts
Join Date:Joined: Jun 2013
More
the antenae itself its basicly a wire with a connector(atleast the phone one), after the drops, the connection maybe got loose. open the phone up(you lost warranty anyways)and disconnect/ re connect the antenae. if dont work, then repair shop.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes