Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,438 Members 44,442 Now Online
XDA Developers Android and Mobile Development Forum

[Q] No root/lost root after updating to Omnirom 4.4.2

Tip us?
 
ScarletCrimson
Old
(Last edited by ScarletCrimson; 14th December 2013 at 02:23 PM.)
#1  
Member - OP
Thanks Meter 6
Posts: 35
Join Date: Jul 2013
Post [Q] No root/lost root after updating to Omnirom 4.4.2

Hi,

As the title says, I've lost root after updating my i9300 to Omnirom 4.4.2. How do I go about rooting it again?

Phone is booting into CWM if I power it off and press Vol Up + Home + Power buttons, I do have a nandroid backup of my previous ROM, can I restore it through CWM without root? On the other hand, Titanium Backup is giving me the error that I don't have root.

I tried installing the SuperSU app from Google Play and selecting TWRP/CWM to install SuperSU binary, it says that it'll reboot into CWM/TWRP to update SuperSU binary. When I press OK, nothing happens.

Please answer the two questions above.

Thanks,
 
JJEgan
Old
#2  
Senior Member
Thanks Meter 4418
Posts: 23,038
Join Date: Oct 2010
Your question has been posted multiple times . Forum rules require you to search before posting .
Google <<< I9300 your search terms > xda

How do I go about rooting it again?
The same method see faqs and guides .


But i suggest you take the time to read the faqs and guides if you do not want to brick .
 
ScarletCrimson
Old
#3  
Member - OP
Thanks Meter 6
Posts: 35
Join Date: Jul 2013
Quote:
Originally Posted by JJEgan View Post
Your question has been posted multiple times . Forum rules require you to search before posting .
Google <<< I9300 your search terms > xda

How do I go about rooting it again?
The same method see faqs and guides .


But i suggest you take the time to read the faqs and guides if you do not want to brick .
Thanks JJEgan. I did try searching but I couldn't find it, sorry.

Previous method I used was CF-Auto Root. Will it work again in Omni ROM? I was afraid it'll brick the phone.
 
tetakpatak
Old
#4  
tetakpatak's Avatar
Senior Member
Thanks Meter 1597
Posts: 3,160
Join Date: Jan 2013
Location: Lucerne
Quote:
Originally Posted by ScarletCrimson View Post
Thanks JJEgan. I did try searching but I couldn't find it, sorry.
Previous method I used was CF-Auto Root. Will it work again in Omni ROM? I was afraid it'll brick the phone.
I see it is nearly 2 weeks since- and the other dude's answer wasn't helpful at all. I will write here so other people can see it.

On the N7100 I had the same problem and I had to install UPDATE-SuperSU-v1.65 by Chainfire through CWM.
It is likely, that the i9300 needs a different file, but that will be described in the opening post Omni ROM for i9300

That solved the problem for me, after several attempts and rebooting....
The Following User Says Thank You to tetakpatak For This Useful Post: [ Click to Expand ]
 
DjoeN
Old
#5  
DjoeN's Avatar
Senior Member
Thanks Meter 144
Posts: 671
Join Date: Aug 2010
Location: Planet Earth
Quote:
Originally Posted by tetakpatak View Post
I see it is nearly 2 weeks since- and the other dude's answer wasn't helpful at all. I will write here so other people can see it.

On the N7100 I had the same problem and I had to install UPDATE-SuperSU-v1.65 by Chainfire through CWM.
It is likely, that the i9300 needs a different file, but that will be described in the opening post Omni ROM for i9300

That solved the problem for me, after several attempts and rebooting....
Just get the UPDATE-SuperSU-v1.65 by Chainfire works perfect for i9300 on OMNI Rom 4.4.2
Father, The Sleeper Has Awaken!
-----------
Google Nexus S (GSM)
- OS: Unofficial Crespo Nightly Kangs [Kitkang] [4.4.x] [cherry-pick]
- Recovery: TWRP 2.7.1.0
-----------
Samsung Galaxy SIII (i9300) Black
- OS 1: CyanogenMod 11 - M9 (4.4.4)
- OS 2: SmartDroid Simple v9.9 (4.3)
- Recovery: TWRP 2.7.1.0
- Baseband version: I9300XXUGNA8
-----------
- Kernel: Boeffla-kernel-2.4 beta_x - i9300
- Kernel: Yank555.lu kernel v4.2 (TouchWiz Roms)
The Following 2 Users Say Thank You to DjoeN For This Useful Post: [ Click to Expand ]
 
Mcordoba
Old
#6  
Junior Member
Thanks Meter 1
Posts: 1
Join Date: Feb 2014
Thumbs up Lost root after omni 4.4.2

Quote:
Originally Posted by DjoeN View Post
Just get the UPDATE-SuperSU-v1.65 by Chainfire[/URL] works perfect for i9300 on OMNI Rom 4.4.2
Works perfect!!! If you had supersu installed, uninstall it, flash this file with Cwm install zip, reboot, install superSU and everything goes smooth. Thank you!
The Following User Says Thank You to Mcordoba For This Useful Post: [ Click to Expand ]
 
2014rokas
Old
#7  
Junior Member
Thanks Meter 6
Posts: 11
Join Date: Mar 2014
Default Installing SUperSU update not enough for me

Quote:
Originally Posted by Mcordoba View Post
Works perfect!!! If you had supersu installed, uninstall it, flash this file with Cwm install zip, reboot, install superSU and everything goes smooth. Thank you!
It was not that easy in my case. I lost root after installing Omni too. I updated SuperSU via CWM, like suggested above, but this did not help. I was fortunate that I had devil kernels recovery, which kinda patches the CWM and adds some new functionalities. One of them is called Re-root system (CWM Superuser) in the devil settings menu. i applied this step, then installed superSU and just after this my device was finally rooted. Fixed!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes