Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Archidroid, included debian error.

OP InFinityWar

15th March 2014, 10:41 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2013
Hi, i have archidroid 2.3.8 , devil kernel ,f2fs. I can't install (for example) update:
Code:
Do you want to continue? [Y/n] Y
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
debconf: falling back to frontend: Readline
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 12938 files and directories currently installed.)
Preparing to unpack .../libc6_2.18-4_armhf.deb ...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
debconf: falling back to frontend: Readline
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: Your kernel version indicates a revision number
of 255 or greater.  Glibc has a number of built in
assumptions that this revision number is less than 255.
If you\'ve built your own kernel, please make sure that any
custom version numbers are appended to the upstream
kernel number with a dash or some other delimiter.

dpkg: error processing archive /var/cache/apt/archives/libc6_2.18-4_armhf.deb (--unpack):
.
How I can fix this ?

Sorry for my bad english :/.
16th March 2014, 03:16 AM   |  #2  
JustArchi's Avatar
Recognized Contributor / Recognized Developer
Flag Warsaw
Thanks Meter: 27,828
 
7,480 posts
Join Date:Joined: Mar 2013
Donate to Me
More
WARNING: Your kernel version indicates a revision number
of 255 or greater. Glibc has a number of built in
assumptions that this revision number is less than 255.
If you\'ve built your own kernel, please make sure that any
custom version numbers are appended to the upstream
kernel number with a dash or some other delimiter

It's clearly stated what's wrong. My pocket debian depends on the running kernel (because it doesn't use any slow emulation or virtualization - it's chrooted environment), so it requires certain things to be GNU-compatible, it looks like devil kernel version is not.
Last edited by JustArchi; 16th March 2014 at 03:32 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes