TWRP 2.8.3.0 Available for Supported Devices

The TeamWin Recovery Project (or TWRP, for short) has quickly become one of the most popular … more

Easily Generate and Export Material Design Palletes

For many people, it can be pretty difficult to create a palette of complementary colors. … more

Android One Expanding to Bangladesh, Nepal, and Sri Lanka

At Google I/O 2013, Google proudly announced that the Android operating system was … more

Android 5.0.2 Fixes 2012 Nexus 7! Sony’s Making a Google Glass Competitor? – XDA TV

Android 5.0.2 Lollipop is available for the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Auto-connect Data on sending/receiving MMS

OP celeronix

16th January 2013, 11:17 AM   |  #1  
OP Senior Member
Flag Varna
Thanks Meter: 22
 
219 posts
Join Date:Joined: Aug 2009
More
Hi everyone
For a long period of time I've been using SlimBean with my old Galaxy S, where it wasn't needed to activate data connection by myself to send or receive MMS. That process was done automatically.
Yesterday I bought S3 and I found out that Samsung and/or Google do not implement this feature in their latest firmwares, which is strange.
I've done a small research in Google and found a post by the member Ouzo here in our forum, who has a resolution for this problem.
Here it is:
Quote:

For me, the fix was to add this line to my 'others.xml' which is located in the System/CSC folder.

<CscFeature_RIL_ForceConnectMMS>true</CscFeature_RIL_ForceConnectMMS>

You need to add the above string before the end of the xml file - the last two lines of it should be:-

</FeatureSet>
</SamsungMobileFeature>


Some people don't have an 'others.xml', they have 'Features.xml' or 'Features_Default.xml' instead.

After editing the xml file, you need to change the permissions back to rw--r--r--
After setting the permissions, reboot.
To make these changes I use ES File Explorer and its built in text editor (it's free).
Needless to say I hope, your phone must be rooted to edit the above file. Make a backup of the file before editing it.

Thanks, Ouzo
I hope that many of you will find this information useful.
Last edited by celeronix; 17th January 2013 at 10:33 AM.
The Following 11 Users Say Thank You to celeronix For This Useful Post: [ View ]
16th January 2013, 12:31 PM   |  #2  
Drug_Store's Avatar
Senior Member
Thanks Meter: 47
 
200 posts
Join Date:Joined: Aug 2006
This actually happend to me...

Came from a long line of HTC models, always had this feature, auto connect to receive MMS.
I was missing this on S3, but now I think we can overcome.

Nice tip, and very nice research. I missed it, but never bothered looking for it.

Thank you
16th January 2013, 01:37 PM   |  #3  
Senior Member
Thanks Meter: 14
 
162 posts
Join Date:Joined: Jul 2010
thanx for this info..
so sad coz im using cm10.1 but cannot find csc folder in system...
16th January 2013, 04:25 PM   |  #4  
Senior Member
Thanks Meter: 164
 
794 posts
Join Date:Joined: Feb 2010
im confused what this does? I have no issues sending or reciving mms. Data connects fine each time. Is it the same as ticking "auto retrieve mms" in the messaging settings?
16th January 2013, 06:39 PM   |  #5  
onesolo's Avatar
Senior Member
Thanks Meter: 99
 
1,925 posts
Join Date:Joined: Apr 2006
More
Quote:

For me, the fix was to add this line to my 'others.xml' which is located in the System/CSC folder.

<CscFeature_RIL_ForceConnectMMS>true</CscFeature_RIL_ForceConnectMMS>

You need to add the above string before the end of the xml file - the last two lines of it should be:-

</FeatureSet>
</SamsungMobileFeature>

Hmm, I opened others.xml but I don't see those two last lines of the document...
My last line is:
</CustomerData>

Should I put like this:
Quote:

....
<CscFeature_RIL_ForceConnectMMS>true</CscFeature_RIL_ForceConnectMMS>
</FeatureSet>
</SamsungMobileFeature>
</CustomerData>

as my last lines ?!?!



Quote:
Originally Posted by skimminstones

im confused what this does? I have no issues sending or reciving mms. Data connects fine each time. Is it the same as ticking "auto retrieve mms" in the messaging settings?

You don't have this issue cause probably you have data ON all the time... so you can send/receive MMS ...
This is for the ones that have DATA OFF, but still want to send/received MMSs!!!

Quote:
Originally Posted by Drug_Store

This actually happend to me...

Came from a long line of HTC models, always had this feature, auto connect to receive MMS.
I was missing this on S3, but now I think we can overcome.

Nice tip, and very nice research. I missed it, but never bothered looking for it.

Thank you

x2!!!
I always had HTC phones before, with winmobile and android, and never had any problems sending/receiving MMSs with data off, but when I put a CM rom on my old Desire HD and got the S3, I then understand that in order to receive/send a MMS I had to turn data on... even the majority of other phones dont do this...
17th January 2013, 10:29 AM   |  #6  
OP Senior Member
Flag Varna
Thanks Meter: 22
 
219 posts
Join Date:Joined: Aug 2009
More
Quote:
Originally Posted by onesolo

Hmm, I opened others.xml but I don't see those two last lines of the document...
My last line is:
</CustomerData>

Should I put like this:
as my last lines ?!?!

Make a backup of the file and try.
I don't expect to occur some fatal error
17th January 2013, 01:27 PM   |  #7  
Senior Member
Flag Melbourne
Thanks Meter: 449
 
1,497 posts
Join Date:Joined: Oct 2010
More
Nice find.

Although I have the others.xml file I actually put it in features.xml. Switched off data to test and it works perfectly. Thanks.

Sent from my GT-I9300 using xda premium
17th January 2013, 01:48 PM   |  #8  
mitky82's Avatar
Senior Member
Flag Sofia
Thanks Meter: 137
 
929 posts
Join Date:Joined: Feb 2011
For some roms dont work.
You need to add other line except this one from thread in others.xml

<CscFeature_Message_EnableMmsMobiledataOff>true</CscFeature_Message_EnableMmsMobiledataOff>

В Българския форум съм пуснал тема със CSC възможности.
Last edited by mitky82; 17th January 2013 at 01:53 PM.
The Following User Says Thank You to mitky82 For This Useful Post: [ View ]
17th January 2013, 04:38 PM   |  #9  
onesolo's Avatar
Senior Member
Thanks Meter: 99
 
1,925 posts
Join Date:Joined: Apr 2006
More
Hell yeah!!!
At Last!!! Finally I'm able to send/receive MMSs with data off!!!

I just found out that the CscFeatures_Message... were all in the feature.xml and not in the others.xml

The line that works for me is this <CscFeature_RIL_ForceConnectMMS>true</CscFeature_RIL_ForceConnectMMS> and not the other. I also tested with the other line and didn't work...

Also, very important to set permissions back to the file and reboot.
Last edited by onesolo; 17th January 2013 at 05:05 PM.
17th January 2013, 05:09 PM   |  #10  
azrieqb's Avatar
Member
Thanks Meter: 21
 
92 posts
Join Date:Joined: Feb 2012
Don't know if it just me, but my s3 have retrieved mms without the data on. My wife s3 don't have data plan but still receive mms without the data on.

I'm still on 4.1.1 because my region which is Malaysia still waiting for the 4.1.2. Is it the issue of this mms only happen on 4.1.2.

Sent from my GT-I9300 using xda app-developers app

Post Reply Subscribe to Thread

Tags
auto-connect, data, mms
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes