Default [Q] Baseband Unknown after flashing Kernel

Hi all,
I have stock 4.3 mk6 with patched mk6 Kernel and modem. However, this problem has been chasing me through different stock roms ( I have tried it on other non stock roms)

For this example, I am trying to flash: boeffla-kernel-5.1-beta4.CWM.zip
I am using Philz latest CWM6 to install the zip.

Right, Whenever I install the Kernel, once I reboot, I get 'No Service'
I have tried to install the patched modem again, but still no network.

If I re install the patched Mk6 Kernel again, all is well.

Can anyone shed some light as to what I am doing wrong please?

I have added some files for you to look at.

Of course I cannot post in the relevant 'development' thread, as I have a low post score.

Many thanks
Attached Thumbnails
Click image for larger version

Name:	2013-12-12 16.44.53.png
Views:	128
Size:	129.1 KB
ID:	2450863   Click image for larger version

Name:	2013-12-12 16.48.26.png
Views:	144
Size:	124.6 KB
ID:	2450864  
Attached Files
File Type: txt boeffla-kernel - Copy.txt - [Click for QR Code] (4.8 KB, 9 views)