Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,852 Members 40,509 Now Online
XDA Developers Android and Mobile Development Forum

[Q] S3 Battery Problem

Tip us?
 
nkomonc
Old
#1  
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Nov 2013
Default [Q] S3 Battery Problem

Hi All,

I have an odd battery problem. My S3 will die and at times when I plug the charger in and the Battery Charging Screen comes up, It shows the battery has more than 50% life. If I unplug the charger and use it, the battery lasts maybe an extra hour but once it reaches about 6% the screen starts flickering and then the mobile network disconnects. I'm sure this is due to low power from the battery.

Any way for me to fix this or to ensure my phone is displaying the correct battery percentage?

See attachment.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-05-02-15-57-14.png
Views:	82
Size:	103.6 KB
ID:	2722141  
 
andrewwright
Old
#2  
andrewwright's Avatar
Senior Member
Thanks Meter 2788
Posts: 5,067
Join Date: Feb 2013
Test new battery. If its not charging while you're using it while plugged in then you have a faulty battery. Don't let the power drop so it shuts down. Try and lend a battery from a friend and test it.
 
kataik95
Old
#3  
Junior Member
Thanks Meter 2
Posts: 16
Join Date: Jan 2013
Location: Debrecen
I have the same problem with my phone. Is it possible that this problem is caused by the custom roms we are using? What do u think? :/

Sent from my GT-I9300 using XDA Free mobile app
 
nkomonc
Old
#4  
Member - OP
Thanks Meter 0
Posts: 32
Join Date: Nov 2013
Quote:
Originally Posted by andrewwright View Post
Test new battery. If its not charging while you're using it while plugged in then you have a faulty battery. Don't let the power drop so it shuts down. Try and lend a battery from a friend and test it.
It charges while I'm using it. Slower but still charges.





Quote:
Originally Posted by kataik95 View Post
I have the same problem with my phone. Is it possible that this problem is caused by the custom roms we are using? What do u think? :/

Sent from my GT-I9300 using XDA Free mobile app
It happens even when I'm using my stock rim. I've reflashed. Installed apps uninstalled apps. Everything


Sent from my GT-I9300 using XDA Free mobile app
 
andrewwright
Old
#5  
andrewwright's Avatar
Senior Member
Thanks Meter 2788
Posts: 5,067
Join Date: Feb 2013
How old is the battery. Power problems nearly always end in an old battery that just needs replacing
 
sunilkumarss
Old
#6  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: May 2014
Default Thanks

i have same issue ...
 
kataik95
Old
#7  
Junior Member
Thanks Meter 2
Posts: 16
Join Date: Jan 2013
Location: Debrecen
Quote:
Originally Posted by andrewwright View Post
How old is the battery. Power problems nearly always end in an old battery that just needs replacing
I bought my phone in 2012 september its quite an old one i guess :sly:

Sent from my GT-I9300 using XDA Free mobile app
 
andrewwright
Old
#8  
andrewwright's Avatar
Senior Member
Thanks Meter 2788
Posts: 5,067
Join Date: Feb 2013
OK well these battery's don't last forever. First thing I would do is ask a friend to lend one and test it for 24hrs. Or just buy one

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes