Default Bootloops on AOSP based roms

Hey there

I'm in need of some help!

Phone: I9300 international 16gb
ROM: PA 4.2 beta 2/4
Kernel: stock PA/Devil v2.3.2/Googy-Max2 v2.1.8/2.2.0/2.2.1 final
Recovery: CWM 6.0.4.6 / Philz touch 6.25.0 / latest devil recovery

Problem:
I came from AOSPA 4.2 beta 1 or 2 (think it was 2) and wanted to try devil kernel with f2fs.
So I downloaded the devil recovery found here:
http://forum.xda-developers.com/show...postcount=1116
and downloaded latest PA (4.2 beta 4 04/09/2014) along with day-0 gapps minimal package.
Also I saved devil kernel to my ext sdcard. Ready to go I thought.

Rebooted to recovery...
Flashed devil recovery...
Rebooted recovery...
Did nandroid backup to ext sdcard...
formated /system /data + /datamedia & /cache as f2fs
Flashed latest PA 4.2 beta4...
Flashed gapps...
Flashed devil kernel...
Wiped data & /cache just to be sure
Rebooted...

After the first boot i got
com.android.phone forceclosing over and over again. As soon as I press the OK button the message reappears, giving me no time at all to sort things out while android is running. Next I rebooted to recovery, formated again (f2fs) did a clean reflash, rebooted and got the same problem.

So I wanted to switch back to my working rom, rebooted to recovery, formated everything back to ext4 and restored my backup.
Just to be sure I wiped /cache & dalvik-cache before i rebooted to my old rom (PA 4.2 beta 2 with googy-max2 v2.2.1).

Boot succeeded but I got the same forceclose. This was the first time I realized something just isn't right. Reboot to recovery, restored AGAIN, flashed devil kernel on top -> bootloop. Tried clean installing PA 4.2 beta 4 without custom kernel -> bootloop, switched recovery to CWM v4.0.4.6 and tried restoring my backup from there -> bootloop.
Thought I messed up my partitions, found an Odin package with CWM 6.0.4.4 included, flashed it together with 16gb .pit file and re-partition checked.
As I had 13 partitions before I can confirm via ADB that it did indeed repartition my sdcard.
Restored my backup -> bootloop, for test purposes I tried latest NeatROM light.
Booted & working like a charm. No hickups.
Updated recovery to latest Philz touch (v6.25 somewhat).

Restoring my backup or flashing PA results in bootloops no matter how eager I format /system /cache /data + /data/media before.
/efs is accessible and seems fine. /preload not so much. I noticed it just after flashing Philz touch recovery that whenever I try to format /preload it failes. Can't even mount it (not in recovery menu, nor via adb).

Could /preload (/dev/block/mmcblk0p10) not being able to mount cause these bootloops? Why would NeatROM run just fine then (Sammy based ROM)? Is the /preload partition supposed to behave like that and if not, what could I do to get things going again?.

I'm pretty desperate for help. Thanks in advance for reading that whole text!


//Edit: I hope this is not considered spam, I posted the same text in another thread!
Galaxy S I9300 | CM11 M7 | Googy-Max kernel v2.3.1 | CPU 1.2GHz @ -125mV | ZZmoove-battery | ROW | MDNIE tweaks | dyn fsync
Nexus 7 (2013) | CM11 nightly | ElementalX kernel v2.13 | CPU 1.35GHz @ -125mV | ElementalX governor | ROW | disabled fsync