Thread Closed

Bricked or power button trouble?

20th April 2014, 05:18 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Dec 2010
A few days ago I looked at my phone and the 'Device Options' menu kept appearing over and over as if someone was holding the power button down. I managed to turn off the phone and since then I haven't been able to get it to reboot. The phone will boot to either the 'SAMSUNG' or 'Samsung Galaxy SIII' logo screens and then the screen goes blank. I can occasionally get the phone to start booting into recovery mode but it turns off before getting to the menu, same thing with download mode. This seems to be getting worse as well, as the first few times I tried to get to recovery mode I could at least get to the menu before it turned off.

The phone will not charge either. I can get the charging indicator (red LED) to come on if I remove battery, plug in USB cable then reinsert battery. However, the battery does not actually get a charge when I do this.

I have tried swapping in fresh batteries, removing SD card, removing SIM card with no effect. I tried taking the phone apart and I can't see any problems with the power switch.

Any ideas on what is going on? I am two months out of warranty. I have ordered a USB jig since I thought it was bricked from a firmware/software issue but now I am wondering if it is actually a power button problem.

The phone is a Rogers Galaxy SIII, not rooted, running stock firmware.

Thanks.
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes